classification
Title: ImageTk.PhotoImage
Type: crash Stage: test needed
Components: Tkinter Versions: Python 2.7
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, jpmieville, srid
Priority: normal Keywords:

Created on 2009-07-07 10:30 by jpmieville, last changed 2009-07-14 05:35 by srid. This issue is now closed.

Files
File name Uploaded Description Edit
Script1.py jpmieville, 2009-07-07 11:44 Script for testing the case
Messages (4)
msg90225 - (view) Author: Jean-Paul Miéville (jpmieville) Date: 2009-07-07 10:30
When using the function ImageTk.PhotoImage. I got the following 
traceback.

    self.chart = ImageTk.PhotoImage(self.image)
  File "C:\Python25\Lib\site-packages\PIL\ImageTk.py", line 116, in 
__init__
    self.paste(image)
  File "C:\Python25\Lib\site-packages\PIL\ImageTk.py", line 181, in 
paste
    import _imagingtk
ImportError: DLL load failed: The specified module could not be found.

_imagintk exists in the directory C:\Python25\Lib\site-packages\PIL

I have re-installed python (ActivePython 2.5.4.4 (r254:67916, Apr 27 
2009, 15:41:14)and PIL and still the same problem.
msg90226 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-07-07 10:45
Can you provide a sample script to reproduce this or try it with a plain
version of python?

From the traceback it looks like ImageTk is something defined by the
PIL, and since it's not part of the stdlib this is probably not the
right place where to report this bug. It could be a problem of
ActiveState Python or of the PIL itself, if you can't reproduce it with
a plain Python try to report it on their bug trackers.

FWIW I found in the doc the class Tkinter.PhotoImage(), if you can
reproduce the problem using it instead of ImageTk.PhotoImage() then it
might be a Python bug.
msg90229 - (view) Author: Jean-Paul Miéville (jpmieville) Date: 2009-07-07 11:44
You are right I think that the problem is related to PIL. I will
reported to the mailing list of PIL.

I have attached a script for testing this case.
msg90512 - (view) Author: Sridhar Ratnakumar (srid) Date: 2009-07-14 05:35
ActivePython bug: http://bugs.activestate.com/show_bug.cgi?id=83694
History
Date User Action Args
2009-07-14 05:35:36sridsetnosy: + srid
messages: + msg90512
2009-07-07 11:44:49jpmievillesetstatus: open -> closed
files: + Script1.py
messages: + msg90229
2009-07-07 10:45:11ezio.melottisetpriority: normal
versions: + Python 2.7, - Python 2.5
nosy: + ezio.melotti

messages: + msg90226

stage: test needed
2009-07-07 10:30:21jpmievillecreate