classification
Title: compile failure in Modules/python.c
Type: Stage:
Components: Versions: Python 3.1
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: adamg, jcsalterego, loewis
Priority: normal Keywords: patch

Created on 2009-06-29 16:30 by adamg, last changed 2010-02-15 21:48 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
python3-cast-fix.patch adamg, 2009-06-29 16:30 buildfix patch
Messages (5)
msg89860 - (view) Author: Adam Golebiowski (adamg) Date: 2009-06-29 16:30
Python-3.1 fails to compile with:
./Modules/python.c: In function 'wchar_t* char2wchar(char*)':
./Modules/python.c:60: error: invalid conversion from 'void*' to 'wchar_t*'

The attached patch fixes this.
msg89864 - (view) Author: Jerry Chen (jcsalterego) Date: 2009-06-29 16:42
On OpenBSD by chance? Looks similar to Issue4146
msg89866 - (view) Author: Adam Golebiowski (adamg) Date: 2009-06-29 16:48
nope, a gcc-4.4 based Linux distribution.

It looks like the same problem happens with Issue4146, but it touches
other part of that file.
msg89880 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-06-29 21:21
Can somebody explain the error? The conversion looks quite valid to me,
so it seems to be a compiler bug.
msg99375 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-02-15 21:48
Closing this as unreproducible.
History
Date User Action Args
2010-02-15 21:48:20loewissetstatus: open -> closed
resolution: works for me
messages: + msg99375
2009-06-29 21:21:10loewissetnosy: + loewis
messages: + msg89880
2009-06-29 16:48:45adamgsetmessages: + msg89866
2009-06-29 16:42:54jcsalteregosetnosy: + jcsalterego
messages: + msg89864
2009-06-29 16:30:40adamgcreate