classification
Title: Upgrading xml.etree to ElementTree 1.3
Type: enhancement Stage:
Components: Library (Lib), XML Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: effbot Nosy List: effbot, orsenthil, rhettinger
Priority: normal Keywords:

Created on 2009-06-12 11:13 by orsenthil, last changed 2009-09-24 04:42 by orsenthil. This issue is now closed.

Messages (4)
msg89270 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2009-06-12 11:13
The current ElementTree package shipped with Python is ElementTree 1.2.6.
ElementTree 1.3 has certain good features in handing XPaths which would
be a nice addition to the default xml.etree.

I don't know why ElementTree 1.2.6 was chosen initially.
I don't find any request for the upgrade.

So opening this one.
msg89271 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2009-06-12 11:20
Oh wait. I read at effbot.org that ElementTree 1.3 is Alpha Release.
Is this the reason for not including it? If it's still unstable, then
please ignore this.
msg89273 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2009-06-12 12:20
Too late for 3.1
msg93051 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2009-09-24 04:42
This is duplicate of Issue1143
History
Date User Action Args
2009-09-24 04:42:46orsenthilsetstatus: open -> closed
resolution: duplicate
messages: + msg93051
2009-06-12 12:20:16rhettingersetnosy: + rhettinger

messages: + msg89273
versions: + Python 3.2, - Python 3.1
2009-06-12 11:20:42orsenthilsetmessages: + msg89271
2009-06-12 11:13:05orsenthilcreate