classification
Title: Fixing several minor bugs in Tkinter.Canvas and one in Misc._configure
Type: behavior Stage: resolved
Components: Tkinter Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: serhiy.storchaka Nosy List: asvetlov, gpolo, iritkatriel, serhiy.storchaka
Priority: normal Keywords: patch

Created on 2009-06-06 21:56 by gpolo, last changed 2020-11-11 18:32 by iritkatriel. This issue is now closed.

Files
File name Uploaded Description Edit
Canvas_fixes.diff gpolo, 2009-06-06 21:56 review
Messages (6)
msg89019 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-06-06 21:56
Hi,

While testing Tkinter.Canvas I've found several minor bugs that I would
prefer to see fixed. Many of them change the current Canvas api a bit,
but for better. For example, the methods "focus", "gettags", "icursor",
"index", "insert", "move" (and some others) accept arbitrary amount of
arguments, but all these tcl subcommands have a fixed amount of
arguments they accept, so I consider it is better to make this clear on
Tkinter too.

I've also found a problem in Misc._configure which is also fixed by the
attached patch. The problem is that when cnf is a string, the call
"self.tk.split(self.tk.call(_flatten((self._w, cmd, '-'+cnf))))" may
still result in an empty string causing the following statement to fail
"return (x[0][1:],) + x[1:]".

One thing that left me curious was the comment "# XXX Should use
_flatten on args" in Canvas.coords. I've tried understanding why it
should use _flatten there, but couldn't figure it out. This is a very
old comment, so maybe it is no longer true ?
msg112880 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-08-04 20:08
msg89019 talks about changing the Canvas API, would this be acceptable?
msg180038 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-01-15 17:16
For backward compatibility we must keep accepting arbitrary amount of arguments at least a one release (with warnings).
msg197769 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-09-15 12:56
See also #19020.
msg380782 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2020-11-11 17:57
Since the code looks so different from the patch now, shall we close this as out of date?
msg380783 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2020-11-11 18:08
I believe, yes
History
Date User Action Args
2020-11-11 18:32:51iritkatrielsetstatus: open -> closed
resolution: out of date
stage: patch review -> resolved
2020-11-11 18:08:47asvetlovsetstatus: pending -> open

messages: + msg380783
2020-11-11 17:57:04iritkatrielsetstatus: open -> pending
nosy: + iritkatriel
messages: + msg380782

2014-02-03 15:48:41BreamoreBoysetnosy: - BreamoreBoy
2013-10-31 16:08:31serhiy.storchakasetassignee: serhiy.storchaka
2013-09-15 12:56:21serhiy.storchakasetmessages: + msg197769
2013-01-15 17:16:44serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg180038
2012-04-06 17:14:13eric.araujosetversions: + Python 3.3, - Python 3.1
2012-04-05 09:54:58asvetlovsetnosy: + asvetlov
2010-08-04 20:08:02BreamoreBoysetversions: + Python 3.2
nosy: + BreamoreBoy

messages: + msg112880

type: behavior
stage: patch review
2009-06-06 21:56:34gpolocreate