classification
Title: Tkinter Scrollbar in OS X 10.5
Type: behavior Stage: resolved
Components: Tkinter Versions: Python 2.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: an is, asvetlov, culler, ned.deily
Priority: normal Keywords:

Created on 2009-05-13 23:01 by an is, last changed 2012-04-03 07:44 by ned.deily. This issue is now closed.

Messages (4)
msg87721 - (view) Author: Jerome (an is) Date: 2009-05-13 23:01
Hi, when I try to use the scrollbar to scroll through the REPL window or 
through a file I'm editing with IDLE in os x 10.5 the image of the 
scroll bar doesn't seem to correspond to anything, it moves more or less 
than my mouse when I'm trying to use it, and sometimes I can't click on 
it at all.  Also, clicking in the empty space to move forward or back a 
page doesn't always work.

~~

Also, I can't scroll the idle window with OS X's built in trackpad 
scrolling feature.  Maybe this isn't a bug thought, is it because idle 
is built with tkinter or something and for this feature to work it needs 
to be built with some os x tool?
msg87829 - (view) Author: Marc Culler (culler) * Date: 2009-05-15 19:53
I have the same issues with Python 2.6 code I have written.  In OS X
10.4 the scrollbars work correctly with a Tkinter Text widget.  The same
code running in 10.5 exhibits this erratic behavior.  It appears as
though mouse movement events are queued up, causing the mouse to get
ahead of the scrollbar.  Later, at some random time, it appears as
though the queued events get processed all at once, causing the
scrollbar to leap ahead of the mouse.  The scrollbar widget display also
becomes corrupted at times, with the blue color from the slider being
written into the buttons at the bottom.
msg157396 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2012-04-03 06:54
Can anybody confirm this bug for OS X?
msg157399 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-04-03 07:44
I am unable to reproduce this behavior with current versions of Python 2.7 or 3.2 on OS X 10.5.8 using either the most recent Apple-supplied Carbon Tcl/Tk 8.4 or with the latest ActiveState Tcl/Tk 8.4 nor with on OS X 10.7 with Tcl/Tk 8.4 or 8.5.  There have been many fixes on the Python side to Tkinter and on the Tcl/Tk side.  If you can reproduce with a current Python 2.7.2 (or later) or 3.2.2 (or later), please reopen with details including which Python build and Tcl/Tk are in use.
History
Date User Action Args
2012-04-03 07:44:30ned.deilysetstatus: open -> closed
versions: + Python 2.6, - Python 3.3
messages: + msg157399

resolution: out of date
stage: resolved
2012-04-03 06:54:32asvetlovsetversions: + Python 3.3, - Python 2.6
nosy: + asvetlov, ned.deily

messages: + msg157396

type: performance -> behavior
2009-05-15 19:53:46cullersettype: performance
title: Scrollbar in Idle os x 10.5 -> Tkinter Scrollbar in OS X 10.5
components: + Tkinter, - IDLE

nosy: + culler
versions: + Python 2.6, - Python 3.1
messages: + msg87829
2009-05-13 23:01:54an iscreate