classification
Title: unnecessary hardlink
Type: behavior Stage:
Components: Installation Versions: Python 3.1
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: exe, orsenthil
Priority: normal Keywords:

Created on 2009-05-08 07:32 by exe, last changed 2009-05-09 04:25 by orsenthil. This issue is now closed.

Messages (2)
msg87428 - (view) Author: Kandalintsev Alexandre (exe) Date: 2009-05-08 07:32
Hello!

After installing py3k:72466 I found that python3 is hardlink to 
python3.1:
$ ls -lai python*
34614 -rwxr-xr-x 2 root root 3625145 2009-05-08 11:10 python3
34614 -rwxr-xr-x 2 root root 3625145 2009-05-08 11:10 python3.1
38299 -rwxr-xr-x 1 root root    1406 2009-05-08 11:10 python3.1-config
34616 lrwxrwxrwx 1 root root      16 2009-05-08 11:10 python3-config -> 
python3.1-config

I'm expecting symlink python3 pointing to python3.1(as python is symlink 
to python2.5 in my system). It's much easy to manage symlinks than 
hardlinks.
msg87482 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2009-05-09 04:21
python3.1 or python2.6 has always been a "hardlink" to the python in the
same directory.
You will see that 
$(LN) python$(VERSION)$(EXE) $(PYTHON)

The one you find as 'softlink' for python2.5 is perhaps ubuntu way of
doing it.
Python installation from source for (Python2.5 also) creates hardlink
only, so this is working as designed.
History
Date User Action Args
2009-05-09 04:25:03orsenthilsetresolution: not a bug -> wont fix
2009-05-09 04:23:58orsenthilsetstatus: open -> closed
2009-05-09 04:23:15orsenthilsetresolution: not a bug
2009-05-09 04:21:18orsenthilsetnosy: + orsenthil
messages: + msg87482
2009-05-08 07:32:28execreate