classification
Title: Add python.exe to the path in windows?
Type: enhancement Stage: test needed
Components: Windows Versions: Python 3.1, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: 1626300 Superseder: Windows installer should add Python and Scripts directories to the PATH environment variable
View: 3561
Assigned To: Nosy List: ajaksu2, loewis, twillis
Priority: normal Keywords:

Created on 2009-03-30 17:27 by twillis, last changed 2009-03-30 19:06 by loewis. This issue is now closed.

Messages (3)
msg84589 - (view) Author: Thomas Willis (twillis) Date: 2009-03-30 17:27
All the vast amounts of documentation out there on how to do neat things
with python seem to assume that python is already in the system path. 

It would be nice if the installer went ahead and set this up for the
user. In my experience there are windows users that don't know how to do
that themselves. As a result, when opening a console(something else
becoming more and more foreign to windows users....) and typing "python"
they get an error and possibly give up, and go back to VB.net or Excel. 

This seems like it would be a relatively easy thing to setup for them
and likely increase world domination.
msg84606 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-03-30 18:32
Thomas,
Thanks for the RFE, but this has been rejected before (see e.g. issue
3561). Please search the tracker and mailing lists for previous
discussions, as you can make a better case based on them.

Also note that issue 1626300 focuses the doc part.

Setting as 'pending' until a patch or a (very) good rationale comes forward.
msg84617 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-03-30 19:06
Actually, closing it as a duplicate of issue3561.
History
Date User Action Args
2009-03-30 19:06:40loewissetstatus: pending -> closed

nosy: + loewis
messages: + msg84617

superseder: Windows installer should add Python and Scripts directories to the PATH environment variable
resolution: duplicate
2009-03-30 18:32:26ajaksu2setstatus: open -> pending

dependencies: + 'Installing Python Modules' does not work for Windows
versions: + Python 3.1, Python 2.7
nosy: + ajaksu2

messages: + msg84606
stage: test needed
2009-03-30 17:27:59twilliscreate