classification
Title: msiexec not creating msvcr90.dll with python -2.6.1.msi
Type: Stage:
Components: Windows Versions: Python 2.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: cjlesh, dykesk, loewis
Priority: normal Keywords:

Created on 2009-03-09 13:40 by cjlesh, last changed 2014-09-25 16:30 by dykesk. This issue is now closed.

Messages (5)
msg83378 - (view) Author: Charles Lesh (cjlesh) Date: 2009-03-09 13:40
When the python-2.6.1.msi installer is run using 'msiexec' from the
windows cmd prompt 'msvcr90.dll' is not created in the installation
directory. I have tried different combination of 'msiexec' command line
switches.

When the python-2.6.1.msi installer is run by double-clicking on it
'msvcr90.dll' is created in the installation directory.

For reference, the python-2.5.*.msi installers would create
'msivcr70.dll' when run with 'msiexec'.
msg101098 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-03-15 12:36
I can't reproduce this. If I run the file with msiexec, then select "install just for me", it will copy msvcr90.dll just fine.
msg227544 - (view) Author: Katherine Dykes (dykesk) Date: 2014-09-25 15:53
Installing for a single user does solve the problem but it is not a good fix.  We have python based software where this has been an issue and a lot of our windows users install python for all users out of habit.  We have to put in the docs to install for a single user, but I'd like to see the issue re-opened.
msg227548 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2014-09-25 16:25
Katherine: Python 2.6 is no longer maintained. If you are talking about a different Python version, please submit a new bug report. Please state
1. what you did
2. what happened
3. what you expected to happen instead
(personally, I'm not willing to invest time into 2.7, either, but somebody else might if that's the version you care about)
msg227549 - (view) Author: Katherine Dykes (dykesk) Date: 2014-09-25 16:30
It is indeed 2.7 with the issues; the software we are building on (OpenMDAO) does not support 3.x - I'll go ahead and submit a new issue for 2.7
History
Date User Action Args
2014-09-25 16:30:29dykesksetmessages: + msg227549
2014-09-25 16:25:29loewissetmessages: + msg227548
2014-09-25 15:53:47dykesksetnosy: + dykesk
messages: + msg227544
2010-03-15 12:36:21loewissetstatus: open -> closed

nosy: + loewis
messages: + msg101098

resolution: works for me
2009-03-09 13:40:29cjleshcreate