classification
Title: os.rename and other raise WindowsError
Type: behavior Stage:
Components: Interpreter Core Versions: Python 3.0, Python 3.1, Python 2.7, Python 2.6, Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: kristjan.jonsson, mrabarnett
Priority: normal Keywords:

Created on 2009-02-06 10:20 by kristjan.jonsson, last changed 2009-02-06 13:36 by kristjan.jonsson. This issue is now closed.

Messages (3)
msg81256 - (view) Author: Kristján Valur Jónsson (kristjan.jonsson) * (Python committer) Date: 2009-02-06 10:20
in lib/test/test_os.py, there is a test class, Win32ErrorTests, that 
tests that certain functions return a WindowsError on failure.  And 
indeed they do that, but that is in contradiction with the 
documentation.  From the 2.6 docs:
 Note
 All functions in this module raise OSError in the case of invalid or
 inaccessible file names and paths, or other arguments that have the
 correct type, but are not accepted by the operating system.
msg81265 - (view) Author: Matthew Barnett (mrabarnett) * (Python triager) Date: 2009-02-06 13:32
WindowsError is a subclass of OSError, so it's not entirely
contradictory, just a little misleading... :-)
msg81266 - (view) Author: Kristján Valur Jónsson (kristjan.jonsson) * (Python committer) Date: 2009-02-06 13:36
ah, well, silly me. then I'll just close this as "Invalid".
History
Date User Action Args
2009-02-06 13:36:40kristjan.jonssonsetstatus: open -> closed
resolution: not a bug
messages: + msg81266
2009-02-06 13:32:06mrabarnettsetnosy: + mrabarnett
messages: + msg81265
2009-02-06 10:20:33kristjan.jonssoncreate