This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: Mark distutils to stay compatible with 2.3
Type: Stage:
Components: Distutils Versions: Python 3.1, Python 2.7
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: tarek Nosy List: akitada, christian.heimes, lemburg, tarek
Priority: normal Keywords: patch

Created on 2009-01-25 13:18 by akitada, last changed 2022-04-11 14:56 by admin. This issue is now closed.

File name Uploaded Description Edit
2.3.patch tarek, 2009-02-27 01:35
Messages (9)
msg80507 - (view) Author: Akira Kitada (akitada) * Date: 2009-01-25 13:18
In distutils package, there are many files that saying
"This module should be kept compatible with Python 2.1."

According to Tarek Ziadé, this is not valid statement anymore.
msg80508 - (view) Author: Akira Kitada (akitada) * Date: 2009-01-25 13:28
If PEP 291 is still valid, distutils needs "only remain compatible with
the version of Python it is distributed with."
msg80545 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-01-25 22:12
done in r68943
msg80546 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2009-01-25 22:23
Note that distutils was removed from PEP 291 in r1982 "After some
discussion at the distutils sprint at PyCon 2005". 

This was not discussed on the distutils mailing list at the time which I
regard as not in line with the way Python or distutils is developed.

While we likely don't need Python 2.1 compatibility anymore, Python 2.3
is still in active use, so keeping distutils Python 2.3 compatible would
allow package authors to use a single distutils version (the Python 2.6
one) to cover the Python releases 2.3 - 2.6.
msg80547 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-01-25 22:34
Ok, I will rewrite the top README file to explain this (and PEP 291 as
well) and keep the Python 2.3 compatibility in the whole package.
msg80551 - (view) Author: Akira Kitada (akitada) * Date: 2009-01-26 00:28
Is there any PEP describing we have to keep compatibility with 2.3 
release? I'm not against the idea but just curious.
msg80965 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2009-02-02 17:33
Some more explanation for why keeping distutils Python 2.3 compatible is

distutils was removed from the PEP without any public discussion outside
a sprint at PyCon and the reasons given for it did not take into account
that people will want to use a single distutils version (that of the
lastest released Python version) to build packages for multiple Python

distutils in Python 2.6 no longer works with Python 2.1, but it still
does mostly with Python 2.3 and I would prefer to have to use that
version as minimum required.

Over the years I've always tried to rework any changes that were done
which did not meet that requirement and only left non-Python 2.3 code
in place that was not relevant for that version anyway, e.g. the
new MSVC code for Python 2.6.

Please also note that distutils is not a performance critical piece of
software. Making it more developer friendly to extending via
sub-classing and more user friendly by adding more support for platform
specific installer format is much more important than using the latest
and greatest tricks in Python.

With Python 2.7 released, we can then move on to Python 2.4
compatibility and so on.
msg82794 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-02-26 23:55
ok the current trunk won't run even under 2.5...

I will make two small changes:

- use md5 module of haslib is not found
- make the smallest possible change for site.USER_BASE 
  and site.USER_SITE usage
msg82831 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-02-27 13:08
And we're back in PEP 291 !

see r70019, r70017 and r70021
Date User Action Args
2022-04-11 14:56:44adminsetgithub: 49302
2009-02-27 13:08:15tareksetstatus: open -> closed
messages: + msg82831
2009-02-27 01:35:11tareksetfiles: + 2.3.patch
keywords: + patch
2009-02-26 23:55:48tareksetnosy: + christian.heimes
messages: + msg82794
2009-02-02 17:33:44lemburgsetmessages: + msg80965
2009-01-26 00:28:45akitadasetmessages: + msg80551
2009-01-25 22:34:17tareksetstatus: closed -> open
messages: + msg80547
title: "This module should be kept compatible with Python 2.1." in distutils code -> Mark distutils to stay compatible with 2.3
2009-01-25 22:23:47lemburgsetnosy: + lemburg
messages: + msg80546
2009-01-25 22:12:42tareksetstatus: open -> closed
messages: + msg80545
2009-01-25 13:29:46tareksetassignee: tarek
nosy: + tarek
versions: - Python 2.6, Python 3.0
2009-01-25 13:28:04akitadasetmessages: + msg80508
2009-01-25 13:18:37akitadacreate