classification
Title: trunc(x) erroneously documented as built-in
Type: Stage:
Components: Documentation, Library (Lib) Versions: Python 3.0, Python 3.1, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: MLModel, georg.brandl, terry.reedy
Priority: normal Keywords:

Created on 2009-01-11 05:37 by MLModel, last changed 2009-01-18 10:48 by georg.brandl. This issue is now closed.

Messages (3)
msg79590 - (view) Author: Mitchell Model (MLModel) Date: 2009-01-11 05:37
In the Numeric Types documentation for 2.6, 3.0, and 3.1 trunc is 
documented as a built-in, like round, but while there is a trunc in math 
there is no built-in trunc. Read some of the debate on trunc from a year 
ago convinced me that this discrepancy is a documentation problem not a 
problem with the built-in functions.  Sorry if I'm completely off target 
here, but since I noticed I figured it was worth an issue.
msg80005 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2009-01-17 07:44
Confirmed for 3.0 that trunc does not exist in the builtins module and
is not listed in the Built-in functions section but is listed in the
Numeric Types section.  So I agree "trunc(x) x truncated to Integral "
should leave the Operation table.

Yes, MM, we do want to clean up such discrepancies.

trunc is in the math module and is listed in its doc.
msg80089 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2009-01-18 10:48
Thanks, fixed in r68721.
History
Date User Action Args
2009-01-18 10:48:24georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg80089
2009-01-17 07:44:57terry.reedysetnosy: + terry.reedy
messages: + msg80005
2009-01-11 05:37:15MLModelcreate