classification
Title: Code to remove in parsetok?
Type: behavior Stage:
Components: Interpreter Core Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, ganderson
Priority: normal Keywords:

Created on 2009-01-07 14:04 by ganderson, last changed 2009-01-07 14:37 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg79332 - (view) Author: (ganderson) Date: 2009-01-07 14:06
At the lines 99 .. 103, there are the message on Python 2.6.
msg79333 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-01-07 14:37
The code is excluded from compilation with a
    #ifdef PY_PARSER_REQUIRES_FUTURE_KEYWORD

There is no __future__ feature in 3.0 for the moment, but the code stays
here as a placeholder, to remind developers what they need to do to
support __future__ flags that change the behavior of the lexer.
History
Date User Action Args
2009-01-07 14:37:22amaury.forgeotdarcsetstatus: open -> closed
resolution: not a bug
messages: + msg79333
nosy: + amaury.forgeotdarc
2009-01-07 14:06:49gandersonsetmessages: + msg79332
2009-01-07 14:04:40gandersoncreate