classification
Title: ERROR: No matching distribution found for kivy
Type: crash Stage: resolved
Components: Installation Versions: Python 3.10
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: mark.dickinson, nikdissv_forever
Priority: normal Keywords:

Created on 2021-06-22 12:24 by nikdissv_forever, last changed 2021-06-22 12:36 by mark.dickinson. This issue is now closed.

Messages (2)
msg396325 - (view) Author: NIKDISSV (nikdissv_forever) Date: 2021-06-22 12:24
An error occurred when installing kiwi on python 3.10.0b3, on Python 3.9.5 there are no errors, but on 3.10 there are:

Collecting kivy
  Using cached Kivy-2.0.0.tar.gz (23.7 MB)
  Installing build dependencies ... error
  ERROR: Command errored out with exit status 1:
   command: 'c:\users\shikardosik\appdata\local\programs\python\python310\python.exe' 'C:\Users\shikardosik\AppData\Local\Temp\pip-standalone-pip-vfw34azi\__env_pip__.zip\pip' install --ignore-installed --no-user --prefix 'C:\Users\shikardosik\AppData\Local\Temp\pip-build-env-lxpt2_oy\overlay' --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- setuptools wheel 'cython>=0.24,<=0.29.21,!=0.27,!=0.27.2' 'kivy_deps.gstreamer_dev~=0.3.1; sys_platform == "win32"' 'kivy_deps.sdl2_dev~=0.3.1; sys_platform == "win32"' 'kivy_deps.glew_dev~=0.3.0; sys_platform == "win32"' 'kivy_deps.gstreamer~=0.3.1; sys_platform == "win32"' 'kivy_deps.sdl2~=0.3.1; sys_platform == "win32"' 'kivy_deps.glew~=0.3.0; sys_platform == "win32"'
       cwd: None
  Complete output (8 lines):
  Collecting setuptools
    Using cached setuptools-57.0.0-py3-none-any.whl (821 kB)
  Collecting wheel
    Using cached wheel-0.36.2-py2.py3-none-any.whl (35 kB)
  Collecting cython!=0.27,!=0.27.2,<=0.29.21,>=0.24
    Using cached Cython-0.29.21-py2.py3-none-any.whl (974 kB)
  ERROR: Could not find a version that satisfies the requirement kivy_deps.gstreamer_dev~=0.3.1 (from versions: none)
  ERROR: No matching distribution found for kivy_deps.gstreamer_dev~=0.3.1
  ----------------------------------------
WARNING: Discarding https://files.pythonhosted.org/packages/12/96/091ddacafb84dd18555a32d860dbfaf9c806147aa30c6f3c8b93cb7bab97/Kivy-2.0.0.tar.gz#sha256=d25e44eb44e43762b2fd0c5874e51954e0f1181fd9800d8a6756be6d084812d8 (from https://pypi.org/simple/kivy/). Command errored out with exit status 1: 'c:\users\shikardosik\appdata\local\programs\python\python310\python.exe' 'C:\Users\shikardosik\AppData\Local\Temp\pip-standalone-pip-vfw34azi\__env_pip__.zip\pip' install --ignore-installed --no-user --prefix 'C:\Users\shikardosik\AppData\Local\Temp\pip-build-env-lxpt2_oy\overlay' --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- setuptools wheel 'cython>=0.24,<=0.29.21,!=0.27,!=0.27.2' 'kivy_deps.gstreamer_dev~=0.3.1; sys_platform == "win32"' 'kivy_deps.sdl2_dev~=0.3.1; sys_platform == "win32"' 'kivy_deps.glew_dev~=0.3.0; sys_platform == "win32"' 'kivy_deps.gstreamer~=0.3.1; sys_platform == "win32"' 'kivy_deps.sdl2~=0.3.1; sys_platform == "win32"' 'kivy_deps.glew~=0.3.0; sys_platform == "win32"' Check the logs for full command output.
  Using cached Kivy-1.11.1.tar.gz (23.6 MB)
msg396326 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2021-06-22 12:36
I'd suggest reporting this on the kivy bug tracker: https://github.com/kivy/kivy

This tracker is for the Python core language, and this doesn't look like a problem caused by a bug in Python.
History
Date User Action Args
2021-06-22 12:36:35mark.dickinsonsetstatus: open -> closed

nosy: + mark.dickinson
messages: + msg396326

resolution: third party
stage: resolved
2021-06-22 12:24:26nikdissv_forevercreate