classification
Title: There is no description of PY_SSIZE_T_CLEAN in docs
Type: Stage: resolved
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, jack__d
Priority: normal Keywords:

Created on 2021-06-16 15:29 by jack__d, last changed 2021-07-21 22:35 by jack__d. This issue is now closed.

Messages (2)
msg395935 - (view) Author: Jack DeVries (jack__d) * Date: 2021-06-16 15:29
In the intro to the C API (https://docs.python.org/3/c-api/intro.html#include-files), it says, "see Parsing arguments and building values for a description of this macro." There is a link which leads to ``arg.rst``, but there is no description of the macro there, just a note to include the macro like elsewhere.

I propose to remove this sentence from the docs, since it is my understanding that there is no need to document the details of why this macro must be defined, only to ensure that users define it.

Alternatively, add a description of the macro in the appropriate place in the C API docs, and fix the link in this blurb.

I'm happy to submit a documentation patch, but I'd need someone to advise on which of these options are more desired.
msg397965 - (view) Author: Jack DeVries (jack__d) * Date: 2021-07-21 22:35
Looking back at this issue, I can see that there is documentation for this in the 'note' block. I'm just going to close this issue.
History
Date User Action Args
2021-07-21 22:35:07jack__dsetstatus: open -> closed
resolution: not a bug
messages: + msg397965

stage: resolved
2021-06-16 15:31:41jack__dsetassignee: docs@python

components: + Documentation
nosy: + docs@python
2021-06-16 15:29:31jack__dcreate