classification
Title: test_asyncio leaked [1533, 1531, 1533] references, sum=4597
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Mark.Shannon, eric.snow, pablogsal, vstinner
Priority: normal Keywords:

Created on 2021-06-04 16:07 by pablogsal, last changed 2021-06-04 22:37 by pablogsal. This issue is now closed.

Messages (4)
msg395096 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-06-04 16:07
All refleak buildbots are currently broken in master:

......
test_asyncio leaked [1533, 1531, 1533] references, sum=4597
test_asyncio leaked [367, 366, 367] memory blocks, sum=1100
11 tests failed again:
    test_asyncgen test_asyncio test_code test_collections
    test_coroutines test_exceptions test_idle test_import test_inspect
    test_modulefinder test_types
== Tests result: FAILURE then FAILURE ==
403 tests OK.
10 slowest tests:
- test_signal: 31 min 10 sec
- test_pydoc: 29 min 41 sec
- test_asyncio: 20 min 3 sec
- test_concurrent_futures: 17 min 35 sec
- test_peg_generator: 13 min 38 sec
- test_gdb: 12 min 20 sec
- test_multiprocessing_spawn: 9 min 33 sec
- test_multiprocessing_forkserver: 6 min 49 sec
- test_nntplib: 6 min 20 sec
- test_multiprocessing_fork: 5 min 41 sec
11 tests failed:
    test_asyncgen test_asyncio test_code test_collections
    test_coroutines test_exceptions test_idle test_import test_inspect
    test_modulefinder test_types
13 tests skipped:
    test_devpoll test_ioctl test_kqueue test_msilib test_ossaudiodev
    test_startfile test_tix test_tk test_ttk_guionly test_winconsoleio
    test_winreg test_winsound test_zipfile64
11 re-run tests:
    test_asyncgen test_asyncio test_code test_collections
    test_coroutines test_exceptions test_idle test_import test_inspect
    test_modulefinder test_types

Example failure:

https://buildbot.python.org/all/#/builders/384/builds/50/steps/5/logs/stdio
msg395100 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-06-04 16:34
This is caused by:

https://bugs.python.org/issue43693
msg395132 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-06-04 22:27
> This is caused by: https://bugs.python.org/issue43693

You reverted the change: https://bugs.python.org/issue43693#msg395105

Can this issue be closed in this case?
msg395133 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-06-04 22:37
Yep
History
Date User Action Args
2021-06-04 22:37:16pablogsalsetstatus: open -> closed
resolution: fixed
messages: + msg395133

stage: resolved
2021-06-04 22:27:52vstinnersetmessages: + msg395132
2021-06-04 16:34:17pablogsalsetnosy: + Mark.Shannon, eric.snow
messages: + msg395100
2021-06-04 16:07:44pablogsalcreate