classification
Title: PyUnicode_Decode is not checked for NULL return value
Type: resource usage Stage:
Components: None Versions: Python 2.5.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CWRU_Researcher1, benjamin.peterson, python-dev
Priority: normal Keywords:

Created on 2008-11-25 01:26 by CWRU_Researcher1, last changed 2011-03-23 01:11 by eric.araujo. This issue is now closed.

Messages (2)
msg76383 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 01:26
Python-2.5.2/Objects/unicodeobject.c(PyUnicodeUCS2_FromEncodedObject)
Line 567

PyUnicode_Decode is not checked for NULL return value
msg76387 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-11-25 02:38
There doesn't need to be a NULL check here. The exception is merely
propagated to the caller.
History
Date User Action Args
2011-03-23 01:11:54eric.araujosetnosy: benjamin.peterson, CWRU_Researcher1, python-dev
messages: - msg131834
2011-03-23 01:11:28python-devsetnosy: + python-dev
messages: + msg131834
2008-11-25 02:38:27benjamin.petersonsetstatus: open -> closed
resolution: not a bug
messages: + msg76387
nosy: + benjamin.peterson
2008-11-25 01:26:38CWRU_Researcher1create