classification
Title: Failure to check return value of PyBool_FromLong for NULL
Type: resource usage Stage:
Components: None Versions: Python 2.5.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CWRU_Researcher1, benjamin.peterson
Priority: normal Keywords:

Created on 2008-11-25 01:01 by CWRU_Researcher1, last changed 2008-11-25 02:40 by benjamin.peterson. This issue is now closed.

Messages (2)
msg76376 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 01:01
/home/rxc92/project/Python-2.5.2/Python/import.c(imp_is_frozen)
Line 2740

Failed to check that the return value of PyBool_FromLong is not NULL

Referenced:
http://www.python.org/doc/2.5.2/api/boolObjects.html#l2h-400
msg76388 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-11-25 02:40
There doesn't need to be a NULL check here. The exception is merely
propagated to the caller.
History
Date User Action Args
2008-11-25 02:40:50benjamin.petersonsetstatus: open -> closed
resolution: not a bug
messages: + msg76388
nosy: + benjamin.peterson
2008-11-25 01:01:35CWRU_Researcher1create