classification
Title: Failure to check PyUnicode_AsUTF8String() return value for NULL
Type: resource usage Stage:
Components: None Versions: Python 2.5.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CWRU_Researcher1, benjamin.peterson
Priority: normal Keywords:

Created on 2008-11-25 00:42 by CWRU_Researcher1, last changed 2008-11-25 02:44 by benjamin.peterson. This issue is now closed.

Messages (2)
msg76373 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 00:42
/home/rxc92/project/Python-2.5.2/Objects/unicodeobject.c(PyUnicodeUCS2_AsEncodedString)
Line 699

Failed to check PyUnicode_AsUTF8String() for returning NULL.

Referenced:
http://www.python.org/doc/2.5.2/api/builtinCodecs.html#l2h-523
msg76390 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-11-25 02:44
This doesn't need a NULL check. The exception is propagated to the caller.
History
Date User Action Args
2008-11-25 02:44:36benjamin.petersonsetstatus: open -> closed
resolution: not a bug
messages: + msg76390
nosy: + benjamin.peterson
2008-11-25 00:42:38CWRU_Researcher1create