classification
Title: Failure to test return value of PyUnicode_AsUTF8String() for NULL
Type: resource usage Stage:
Components: None Versions: Python 2.5.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: CWRU_Researcher1, benjamin.peterson
Priority: normal Keywords:

Created on 2008-11-25 00:39 by CWRU_Researcher1, last changed 2008-11-25 02:49 by benjamin.peterson. This issue is now closed.

Messages (2)
msg76372 - (view) Author: Brian Szuter (CWRU_Researcher1) Date: 2008-11-25 00:39
/home/rxc92/project/Python-2.5.2/Parser/tokenizer.c
(translate_into_utf8) Line 573
The return value of PyUnicode_AsUTF8String() is never checked if it is NULL.

Reference:
http://www.python.org/doc/2.5.2/api/builtinCodecs.html#l2h-523
msg76393 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-11-25 02:49
There are already NULL checks.
History
Date User Action Args
2008-11-25 02:49:45benjamin.petersonsetstatus: open -> closed
resolution: not a bug
messages: + msg76393
nosy: + benjamin.peterson
2008-11-25 00:39:48CWRU_Researcher1create