classification
Title: argparse.REMAINDER missing in online documentation for 3.9.x
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.10, Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: paul.j3, rhettinger, shihai1991, smac89
Priority: normal Keywords:

Created on 2021-02-27 19:57 by smac89, last changed 2021-03-01 04:35 by smac89. This issue is now closed.

Messages (4)
msg387786 - (view) Author: Chigozirim Chukwu (smac89) Date: 2021-02-27 19:57
Since 3.9.0, the online documentation for the argparse module is missing reference for argparse.REMAINDER.

If the feature has been deprecated, can we get atleast a mention in the deprecation notes as to what one should now prefer.

If it was just a mistake, then I guess I'm just here to bring some attention to it.

Thanks
msg387811 - (view) Author: hai shi (shihai1991) * (Python triager) Date: 2021-02-28 17:10
Hi, Chigozirim Chukwu. Thanks for your report.

There have releated comment in: https://bugs.python.org/issue17050#msg315716
msg387812 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2021-02-28 18:20
Chigozirim, thanks for the report.

REMAINDER is now an undocumented legacy feature.  It isn't deprecated because we don't plan to remove it.  It isn't documented because it is buggy in a way that isn't easy to fix.
msg387838 - (view) Author: Chigozirim Chukwu (smac89) Date: 2021-03-01 04:35
Alright thanks for the info everyone
History
Date User Action Args
2021-03-01 04:35:38smac89setmessages: + msg387838
2021-02-28 18:20:42rhettingersetstatus: open -> closed
resolution: not a bug
messages: + msg387812

stage: resolved
2021-02-28 17:10:14shihai1991setnosy: + shihai1991, rhettinger, paul.j3

messages: + msg387811
versions: + Python 3.10
2021-02-27 19:57:15smac89create