classification
Title: < test.support > check_free_after_iterating( ) causes core dump in handling iteration.
Type: crash Stage: resolved
Components: Library (Lib) Versions: Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: CharlesFengY, Mark.Shannon, iritkatriel, terry.reedy
Priority: normal Keywords:

Created on 2021-02-10 09:48 by CharlesFengY, last changed 2021-03-02 11:53 by Mark.Shannon. This issue is now closed.

Messages (4)
msg386768 - (view) Author: Yang Feng (CharlesFengY) Date: 2021-02-10 09:48
In the following program, we call check_free_after_iterating( ) twice, in the second time, we recursively call function test_free_after_iterating(). Python interpreter crashes.
+++++++++++++++++++++++++++++++++++++++++++
import unittest
import test.support

class UnicodeTest(unittest.TestCase):
	pass

def test_free_after_iterating():
    ut = UnicodeTest()
    test.support.check_free_after_iterating(ut, iter, str)
    test.support.check_free_after_iterating(str, test_free_after_iterating(), str)

test_free_after_iterating()
+++++++++++++++++++++++++++++++++++++++++

System Info: Ubuntu 16.04
Python Version:  Python 3.9.1
msg386784 - (view) Author: Irit Katriel (iritkatriel) * (Python triager) Date: 2021-02-10 15:04
This looks similar to 43185.
msg386909 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2021-02-13 05:10
I suspect this is another duplicate of #43185
msg387920 - (view) Author: Mark Shannon (Mark.Shannon) * (Python committer) Date: 2021-03-02 11:53
On 3.10a, this raises a RecursionOverflow
History
Date User Action Args
2021-03-02 11:53:50Mark.Shannonsetstatus: open -> closed
resolution: duplicate
stage: resolved
2021-03-02 11:53:29Mark.Shannonsetnosy: + Mark.Shannon
messages: + msg387920
2021-02-13 05:10:26terry.reedysetnosy: + terry.reedy
messages: + msg386909
2021-02-10 15:04:10iritkatrielsetnosy: + iritkatriel
messages: + msg386784
2021-02-10 09:48:57CharlesFengYcreate