classification
Title: Can't input Japanese on idle (MacOS).
Type: behavior Stage: resolved
Components: macOS, Tkinter Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: terry.reedy Nosy List: Marusoftware, epaine, ned.deily, ronaldoussoren, terry.reedy
Priority: normal Keywords:

Created on 2021-02-05 10:43 by Marusoftware, last changed 2021-02-06 11:31 by ronaldoussoren. This issue is now closed.

Messages (5)
msg386523 - (view) Author: Marusoftware (Marusoftware) Date: 2021-02-05 10:43
Can't input Japanese text to idle on MacOS.
I think this caused by "https://core.tcl-lang.org/tk/tktview?name=39de9677aa".
So, builtin tk&tcl upgrade is required.
msg386524 - (view) Author: E. Paine (epaine) * Date: 2021-02-05 11:07
Can you please test to see whether this occurs on 3.10.0a5 using the Universal2 installer?
msg386529 - (view) Author: Marusoftware (Marusoftware) Date: 2021-02-05 15:45
Thank you for replying.
I tried as you said.
This issue is not occurs on 3.10.0a5.
Thank you very much.

But when want to use python 3.8 or 3.9 and others, I can't use this...
If you are OK, generate patches.
But this is really hard...
So, this is optionally.

Anyway this issue is solved by using 3.10.
But, 3.10 is now preview...I'm wait for release...
msg386537 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2021-02-05 19:05
The change in 3.10 is installing tk 8.6.11 instead of 8.6.8. This would have been or would be backported if and only if Ned and Ronald think it both possible and wise.  As with most tkinter issues, this affects IDLE but is not an IDLE issue as such.  The universal2 installer is still listed as experimental, though now it seems to be pretty solid.
msg386556 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2021-02-06 11:31
As the issue is gone with the 3.10 universal2 installer it should also be gone with the 3.9.1 universal installer. I'd expect that the difference is in the use of a newer version of Tcl/Tk. 

We haven't used the newer versions of Tcl/Tk with the regular 3.9 installer because we (or rather Ned) have run into various issues when building recent versions of Tcl/Tk on ancient versions of macOS. The universal2 installer is build on macOS 11 and hence avoids those build issues.  

Testing if Tcl/Tk 8.6.11 works correctly when build on macOS 10.9 could be an interesting experiment if someone is up to this, but is something I don't intend to do.  I rarely use Tkinter myself and this requires manual testing to verify behaviour.
History
Date User Action Args
2021-02-06 11:31:24ronaldoussorensetmessages: + msg386556
2021-02-05 19:05:03terry.reedysetstatus: open -> closed

nosy: + ronaldoussoren, ned.deily
messages: + msg386537

components: + macOS, - IDLE
stage: resolved
2021-02-05 15:46:15Marusoftwaresetresolution: fixed
2021-02-05 15:45:06Marusoftwaresetmessages: + msg386529
2021-02-05 11:07:53epainesetnosy: + epaine
messages: + msg386524
2021-02-05 10:45:10Marusoftwaresettitle: Can't input Japanese. -> Can't input Japanese on idle (MacOS).
2021-02-05 10:43:07Marusoftwarecreate