classification
Title: parseaddr (from email.utils) returns invalid input string instead of ('', '')
Type: behavior Stage: resolved
Components: email Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: barry, lbenc135, r.david.murray
Priority: normal Keywords:

Created on 2021-02-01 11:37 by lbenc135, last changed 2021-02-01 12:53 by r.david.murray. This issue is now closed.

Messages (2)
msg386062 - (view) Author: Livio Bencik (lbenc135) Date: 2021-02-01 11:37
```
from email.utils import parseaddr
parseaddr('randomstring')
```

returns ('', 'randomstring'), instead of ('', '') as the documentation says.
msg386065 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2021-02-01 12:53
The return value is correct.  Interpreted as an email address, 'randomstring' is a local mailbox.
History
Date User Action Args
2021-02-01 12:53:03r.david.murraysetstatus: open -> closed
resolution: not a bug
messages: + msg386065

stage: resolved
2021-02-01 11:37:39lbenc135create