classification
Title: Blank in multiline “if expressions” will lead to EOF errors
Type: compile error Stage: resolved
Components: Interpreter Core Versions: Python 3.10
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: lys.nikolaou, pablogsal, xxm
Priority: normal Keywords:

Created on 2021-01-13 06:05 by xxm, last changed 2021-02-09 22:29 by pablogsal. This issue is now closed.

Messages (4)
msg384996 - (view) Author: Xinmeng Xia (xxm) Date: 2021-01-13 06:05
In build-in function compile() of mode 'single',  single statement can be well compiled. (see program 1 and program 2). However,  if we leave 4 blank spaces before the end of triple-quotation mark of "if expression",(see program 3), The parser will raise syntax error. This is not the expected output.  Spaces in the end of multi-line expression should not affect the compilation results. No error should be reported in this case.


program 1 (expected)
===============================
snippet ="""
a = 1
     """
compile(snippet, "", "single")
===============================

program 2 (expected)
===============================
snippet ="""
if True:
     a = 1
"""
compile(snippet, "", "single")
===============================

program 3 (unexpected)
===========================
snippet ="""
if True:
     a = 1
     """
compile(snippet, "", "single")
===========================
Traceback (most recent call last):
     File "/home/xxm/Desktop/nameChanging/report/test1.py", line 1, in <module>
         compile(snippet, "", "single")
     File "", line 4
SyntaxError: unexpected EOF while parsing

Expected output: No error reported (like program1 and program2)


>> python -V
Python 3.10.0a2
>>uname -a
Linux xxm-System-Product-Name 4.15.0-64-generic #73~16.04.1-Ubuntu SMP Fri Sep 13 09:56:18 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
msg386541 - (view) Author: Lysandros Nikolaou (lys.nikolaou) * (Python committer) Date: 2021-02-05 22:24
I can't really understand if this should be considered a bug or not. It's definitely consistent with 3.8 and my inclination that it is not.
msg386543 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-02-05 23:23
Yeah, I also believe this doesn't look like a bug and the fact that is consistent with 3.8 makes me more confident to say that is not.
msg386747 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2021-02-09 22:29
Closing as "not a bug" as per the previous discussion. If someone sees new information here, please, feel free to re-open.
History
Date User Action Args
2021-02-09 22:29:47pablogsalsetstatus: open -> closed
resolution: not a bug
messages: + msg386747

stage: resolved
2021-02-05 23:23:10pablogsalsetmessages: + msg386543
2021-02-05 22:24:45lys.nikolaousetnosy: + pablogsal
messages: + msg386541
2021-01-13 06:28:27gvanrossumsetnosy: + lys.nikolaou
2021-01-13 06:05:45xxmcreate