classification
Title: parsermodule and grammar variable
Type: compile error Stage: patch review
Components: Build, Tests, Windows Versions: Python 3.0, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder: Module 'parser' fails to build
View: 4279
Assigned To: Nosy List: christian.heimes, kirkshorts, loewis, msapiro, rpetrov
Priority: normal Keywords: patch

Created on 2008-11-09 12:34 by rpetrov, last changed 2009-01-11 09:35 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
parser-grammar.patch rpetrov, 2008-11-09 12:34 parser-grammar.patch
Messages (8)
msg75652 - (view) Author: Roumen Petrov (rpetrov) * Date: 2008-11-09 12:34
After synchronization of my mingw32 cross-compilation environment with
trunk some of tests fail. The reason is that parsermodule fail to link.

Please check build on officially supported platform: MSVC and cygwin.

The attached patch (parser-grammar.patch) solve issue in my environment.
msg75657 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-11-09 18:19
As far as I know neither cygwin nor MinGW32 are falling under the
categoy of first class citizens. MinGW32 is only officially supported to
build extension modules. The compilers aren't used by our build bots, too.

In order to make both cygwin builds and MinGW32 compiler major platforms
somebody has to step up and constantly provides testing and patches.
msg75658 - (view) Author: Andy (kirkshorts) Date: 2008-11-09 18:51
looks like it might be a similar root issue to the one I raised in #4279.

Looks like this patch breaks the data hiding that I think has been
attempted :-( though it doesn't mess with setup.py in the way mine does :-)

Don't know how Christian's comment affects either of our patches though
(still an uber newbie to the whole contributing to Python thing ;-) )
msg75659 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-11-09 19:00
Andy:
Of course we like to support Cygwin and MinGW32. I wanted to make clear
that the platforms aren't top priority. They aren't regularly tested by
any of the core developers and build bots.

Regarding data hiding, you are correct. I'm more fond of your solution #4279
msg75660 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-11-09 19:04
Oh, I retract everything I said about your patch. I didn't read your
patch carefully enough. With your patch the parser module wouldn't use
the same grammer as the rest of Python. That might be an issue.
msg75661 - (view) Author: Andy (kirkshorts) Date: 2008-11-09 19:31
Christian:

Cool, thanks for the feedback d00d - it took longer than i though to get
what I predicted :-) No worries on the whole "core target" platform
thing - I understand it perfectly, had the same issue for work related
things: too many platform and too few test resources :-( And sadly I am
in not a position to gift any to the cause - sorry.

Can I ask how it would mean that parser would get a different grammar?
In the interests of a newbie learning if you don't mind (maybe post the
reply to #4279 as I guess it is more relevant there than here)
msg75662 - (view) Author: Andy (kirkshorts) Date: 2008-11-09 19:42
Christian: sorry my 'find' kung fu is weak :-( :-$ I see why.

Will work on a better patch.
msg79593 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2009-01-11 09:35
This is now fixed with the resolution to issue 4279.
History
Date User Action Args
2009-01-11 09:35:19loewissetstatus: open -> closed
resolution: fixed
superseder: Module 'parser' fails to build
messages: + msg79593
2009-01-10 23:00:35msapirosetnosy: + msapiro
2008-11-09 19:42:46kirkshortssetmessages: + msg75662
2008-11-09 19:31:12kirkshortssetmessages: + msg75661
2008-11-09 19:04:14christian.heimessetmessages: + msg75660
2008-11-09 19:00:25christian.heimessetmessages: + msg75659
2008-11-09 18:51:01kirkshortssetnosy: + kirkshorts
messages: + msg75658
2008-11-09 18:19:39christian.heimessetversions: + Python 3.0
nosy: + loewis, christian.heimes
messages: + msg75657
priority: normal
components: + Windows
type: compile error
stage: patch review
2008-11-09 12:34:28rpetrovcreate