classification
Title: Python 2.6 64-bit + Vista 64 = Bad MSVCRT
Type: crash Stage:
Components: Windows Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: "for me" installer problem on x64 Vista
View: 4018
Assigned To: Nosy List: DaGoodBoy, loewis
Priority: normal Keywords:

Created on 2008-11-08 19:09 by DaGoodBoy, last changed 2008-11-08 19:29 by loewis. This issue is now closed.

Messages (2)
msg75643 - (view) Author: Anthony Awtrey (DaGoodBoy) Date: 2008-11-08 19:09
Here is the reproduction process. Get Windows box running Vista 64-bit.
Download the Python 2.6 64-bit version. Write a script that imports
escape from saxutils. See this:

C:\Python26>python.exe example_xml_script.py > out.xml
Traceback (most recent call last):
  File "example_xml_script.py", line 11, in <module>
    from xml.sax.saxutils import escape
  File "C:\Python26\lib\xml\sax\saxutils.py", line 6, in <module>
    import os, urlparse, urllib, types
  File "C:\Python26\lib\urllib.py", line 26, in <module>
    import socket
  File "C:\Python26\lib\socket.py", line 46, in <module>
    import _socket
ImportError: DLL load failed: The application has failed to start
because its side-by-side configuration is incorrect. Please see the
application event log for more detail.

EventViewer says:

Activation context generation failed for "C:\Python26\DLLs\_socket.pyd".
Error in manifest or policy file
"C:\Python26DLLs\Microsoft.VC90.CRT.MANIFEST" on line 12. 
The value "../msvcr90.dll" of attribute "name" in element
"urn:schemas-microsoft-com:asm.v1^file" is invalid.

Go download the MSVCRT directly and install it:

http://www.microsoft.com/downloads/details.aspx?familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en

Then the problem goes away.

This issue is particular only to the Python 2.6 64-bit version, as the
32-bit version runs just fine.
msg75646 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-11-08 19:29
This is a duplicate of Issue4018. You need to install Python "for all
users"; "just for me" installation is not supported.
History
Date User Action Args
2008-11-08 19:29:22loewissetstatus: open -> closed
2008-11-08 19:29:17loewissetresolution: duplicate
superseder: "for me" installer problem on x64 Vista
messages: + msg75646
nosy: + loewis
2008-11-08 19:09:48DaGoodBoycreate