classification
Title: Maildir dumpmessage on
Type: Stage:
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: marcus@internetnowasp.net, petri.lehtinen, terry.reedy
Priority: normal Keywords:

Created on 2008-11-03 08:18 by marcus@internetnowasp.net, last changed 2012-08-17 04:34 by petri.lehtinen. This issue is now closed.

Messages (3)
msg75463 - (view) Author: Marcus CM (marcus@internetnowasp.net) Date: 2008-11-03 08:18
When using maildir on windows, the maildir._dump_message erronously 
added "\r\n" to "\r\r\n" : in mailbox.py

target.write(buffer.read().replace('\n', os.linesep))
msg107983 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-06-17 01:48
This report is a bit hard to interpret. In 3.1, the mailbox module has a Maildir class with a private _dump_message method. Since the method is undocumented and not part of the public API, there cannot be a conflict between the doc and behavior ;-).

So you need to show with minimal but complete code, and now, with 2.7 or 3.1, that there is a bug in a public method caused by its use of the private method.

I do not see what the code line has to do with the report.
msg168431 - (view) Author: Petri Lehtinen (petri.lehtinen) * (Python committer) Date: 2012-08-17 04:34
No reply in two years, closing.
History
Date User Action Args
2012-08-17 04:34:26petri.lehtinensetstatus: open -> closed

nosy: + petri.lehtinen
messages: + msg168431

resolution: not a bug
2010-06-17 01:48:56terry.reedysetnosy: + terry.reedy

messages: + msg107983
versions: + Python 2.7, - Python 2.5
2008-11-03 08:18:44marcus@internetnowasp.netcreate