classification
Title: email.LazyImporter does not use absolute imports
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 2.6
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: r.david.murray Nosy List: barry, brandonbloom, loewis, r.david.murray
Priority: normal Keywords:

Created on 2008-10-27 05:57 by brandonbloom, last changed 2010-12-27 20:28 by r.david.murray. This issue is now closed.

Messages (3)
msg75251 - (view) Author: Brandon Bloom (brandonbloom) Date: 2008-10-27 05:57
I have a package with a module called "email". If I try to use the 
standard email package, it fails to load email.Utils because 
email.LazyImporter is looking in my email module instead of the top-
level email package.
msg77494 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-12-10 08:30
No patch has been proposed, so the issue is not eligible for 2.5.3.
msg124734 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-12-27 20:28
LazyImporter isn't used in Python3.  Without someone motivated to propose a patch this isn't going to be changed, so I'm closing the issue.
History
Date User Action Args
2010-12-27 20:28:18r.david.murraysetstatus: open -> closed
nosy: loewis, barry, brandonbloom, r.david.murray
messages: + msg124734

resolution: wont fix
stage: resolved
2010-05-05 13:50:53barrysetassignee: barry -> r.david.murray

nosy: + r.david.murray
2008-12-10 08:30:26loewissetnosy: + loewis
messages: + msg77494
versions: + Python 2.6, - Python 2.5.3
2008-10-27 15:53:09benjamin.petersonsetassignee: barry
nosy: + barry
2008-10-27 05:57:20brandonbloomcreate