classification
Title: No hyphen in broken up word in documentation
Type: Stage: resolved
Components: Documentation Versions: Python 3.10, Python 3.9, Python 3.8
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Mariatta, barry, cryvate, docs@python, mdk, rhettinger, terry.reedy
Priority: normal Keywords:

Created on 2020-10-09 20:44 by cryvate, last changed 2020-10-20 00:25 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
Screenshot 2020-10-09 at 21.43.50.png cryvate, 2020-10-09 20:44 Shows example in browser
Screen Shot 2020-10-19 at 16.46.44.png barry, 2020-10-19 23:48
Messages (7)
msg378351 - (view) Author: Henk-Jaap Wagenaar (cryvate) * Date: 2020-10-09 20:44
In the decimal module documentation:

https://docs.python.org/3/library/decimal.html

Arithmetic is broken up for me as "Arith\nmetic", not the missing hyphen, unless I am mistaken it should be "Arith-\nmetic". Is this a Sphinx issue? Is this a browser issue? Is this an issue on our end? Later it does break "Applications" correctly.

See attached screenshot.
msg378352 - (view) Author: Mariatta (Mariatta) * (Python committer) Date: 2020-10-09 21:00
In the source code, we wrote it as "arithmetic" in one word.

https://raw.githubusercontent.com/python/cpython/master/Doc/library/decimal.rst

So I think this is either Sphinx or Docutils issue.
msg378473 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2020-10-12 07:12
I've been seeing this throughout the docs.
msg378746 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-10-16 20:34
I am closing because word breakage when wrapping and justifying is an OS-browswer issue.  I see the image as having two hyphenation bugs, but whoever wrote that viewer might disagree.

The displayed paragraph is the first bullet point in the doc.  With Firefox on Windows 10, the default wrapping (narrower than my full screen width) is after 'paramont' and 'learn at'.

  Decimal “is based on a floating-point model which was designed with people in mind, and necessarily has a paramount
  guiding principle – computers must provide an arithmetic that works in the same way as the arithmetic that people learn at
  school.” – excerpt from the decimal arithmetic specification.

If I enlarge the text with Cntl-Mousewheel, even up to to the max 300%, Firefox rewraps but never breaks words; it only justifies with spaces.

With MS Edge and Google Chrome, the default breaks are after 'has a' and 'as the' and the max enlargements are 400/500%, but the behavior is otherwise the same -- rewrapping and justification with spaces, no word breaks.

  Decimal “is based on a floating-point model which was designed with people in mind, and necessarily has a
  paramount guiding principle – computers must provide an arithmetic that works in the same way as the
  arithmetic that people learn at school.” – excerpt from the decimal arithmetic specification.

Safari on my Macbook Mohave, does break words, and has nec-essarily, arith-metic, and ap-plication (later in the text), which are correct.

In the image, rewrapping is done by breaking words according to some local algorithm.  Short pieces as in ne-cessarily and ap-plications are hyphenated but the 'big' pieces of arith metic are not.  This looks like a browser bug, but might be a local standard.  According to both Google and my paper dictionary, the first hyphenation should be nec-essarily, as in Safari, which is an exception to the general rule of 'before a single consonant', as in spe-ci-fi-ca-tion.  But maybe some group disagrees with this exception.
msg378747 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-10-16 20:35
Raymond, what viewer are you using when you see unhyphenated word breaks?
msg379064 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2020-10-19 23:48
I am seeing this in Brave (a Chrome derivative).  Many examples in https://docs.python.org/3/library/email.html

See the words "in\nterface" and "ob\nject' in the attached screenshot.
msg379069 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-10-20 00:25
Perhaps send the screenshot to the Brave devs, along with the doc url.
History
Date User Action Args
2020-10-20 00:25:28terry.reedysetmessages: + msg379069
2020-10-19 23:48:02barrysetfiles: + Screen Shot 2020-10-19 at 16.46.44.png
nosy: + barry
messages: + msg379064

2020-10-16 20:35:28terry.reedysetmessages: + msg378747
2020-10-16 20:34:25terry.reedysetstatus: open -> closed

nosy: + terry.reedy, mdk
messages: + msg378746

resolution: third party
stage: resolved
2020-10-12 07:12:57rhettingersetnosy: + rhettinger
messages: + msg378473
2020-10-09 21:00:31Mariattasetnosy: + Mariatta
messages: + msg378352
2020-10-09 20:44:30cryvatecreate