classification
Title: Allow assignment in yield statement
Type: enhancement Stage: resolved
Components: Versions: Python 3.10
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: conqp, ronaldoussoren
Priority: normal Keywords:

Created on 2020-09-16 08:46 by conqp, last changed 2020-09-16 09:27 by ronaldoussoren. This issue is now closed.

Messages (3)
msg376979 - (view) Author: Richard Neumann (conqp) * Date: 2020-09-16 08:46
I often write factory (deserialization) methods for ORM models for web application backends that produce a number of records (ORM model instances) of itself and related database tables:

    @classmethod
    def from_json(cls, json):
        """Yields records from a JSON-ish dict."""
        modules = json.pop('modules', None) or ()
        order = super().from_json(json)
        yield order

        for module in modules:
            yield OrderedModule(order=order, module=Module(module))

This yields the main record "order" and related records from OrderedModules, which have a foreign key to Order.
Thusly I can save all records by:

    for record in Order.from_json(json):
        record.save()

Since I have several of those deserialization functions for multiple tables in multiple databases, it'd be nice to reduce the amount of code with some extra syntactic sugar, like:

    @classmethod
    def from_json(cls, json):
        """Yields records from a JSON-ish dict."""
        modules = json.pop('modules', None) or ()
        yield order = super().from_json(json)  # Assignment via "="

        for module in modules:
            yield OrderedModule(order=order, module=Module(module))

or:

    @classmethod
    def from_json(cls, json):
        """Yields records from a JSON-ish dict."""
        modules = json.pop('modules', None) or ()
        yield order := super().from_json(json)  # Assignment via ":="

        for module in modules:
            yield OrderedModule(order=order, module=Module(module))

I therefor propose to allow assignment of names in generator-like yield statements as described above.
msg376980 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-09-16 09:03
You can already do this with the walrus operator:

# ---
def test():
    for i in range(10):
        yield (square := i * i)

        yield square + 1

# ---

This adds some parenthesis to your second alternative.
msg376981 - (view) Author: Richard Neumann (conqp) * Date: 2020-09-16 09:09
Awesome, I didn't know that.
I tried it without the parens and it gave me a SyntaxError.
This can be closed then as it's obviously already implemented.
Let's get to refactoring.
History
Date User Action Args
2020-09-16 09:27:04ronaldoussorensetstatus: open -> closed
resolution: not a bug
stage: resolved
2020-09-16 09:09:49conqpsetmessages: + msg376981
2020-09-16 09:03:29ronaldoussorensetnosy: + ronaldoussoren
messages: + msg376980
2020-09-16 08:46:53conqpcreate