classification
Title: Docs: Please remove `from distutils.core import setup`
Type: Stage: resolved
Components: Distutils Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: dstufft, eric.araujo, guettli, terry.reedy
Priority: normal Keywords:

Created on 2020-09-10 20:29 by guettli, last changed 2020-10-22 22:51 by terry.reedy. This issue is now closed.

Messages (5)
msg376695 - (view) Author: Thomas Guettler (guettli) Date: 2020-09-10 20:29
Please remove this page or at least the code snippet 
containing `from distutils.core import setup`
on this page: https://docs.python.org/3/distutils/setupscript.html

There is the more up to date doc here: https://packaging.python.org/tutorials/packaging-projects/#creating-setup-py

Quoting Zen o Py: There should be one-- and preferably only one --obvious way to do it.

Thank you very much!
msg376761 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-09-12 01:31
There is discussion on pydev about formally deprecating distutils, which would deprecate that snippet.
msg379336 - (view) Author: √Čric Araujo (eric.araujo) * (Python committer) Date: 2020-10-22 20:09
That page is documenting distutils, so it is correctly showing a distutils import.  The page also starts with a note linking to setuptools doc.  Therefore, I would close this ticket.
msg379376 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-10-22 22:49
In that case, I agree.
msg379377 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-10-22 22:51
But notice that even agreeing removes 'pending', making it pretty useless.
History
Date User Action Args
2020-10-22 22:51:04terry.reedysetstatus: open -> closed

messages: + msg379377
stage: resolved
2020-10-22 22:49:58terry.reedysetstatus: pending -> open

messages: + msg379376
2020-10-22 20:09:46eric.araujosetstatus: open -> pending
resolution: not a bug
messages: + msg379336
2020-09-19 18:59:37iritkatrielsetcomponents: + Distutils
2020-09-12 01:31:54terry.reedysetnosy: + terry.reedy, eric.araujo, dstufft
messages: + msg376761
2020-09-10 20:29:13guettlicreate