classification
Title: Turtles in Python 3.8.5 crashes OSX 10.14.6
Type: crash Stage: resolved
Components: macOS Versions: Python 3.8
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: dulcimoo, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2020-08-31 18:24 by dulcimoo, last changed 2020-10-19 20:22 by ned.deily. This issue is now closed.

Messages (4)
msg376159 - (view) Author: Weyl (dulcimoo) Date: 2020-08-31 18:24
The following python sequence will crash OSX 10.14.6 and Python 3.8

import turtle
theScreen=turtle.Screen()
mertle=turtle.Turtle()
msg376181 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-09-01 06:46
Thanks for the report. However, you are going to have give more specific information for us to be able to try to understand and reproduce the problem. Exactly what steps did you use to show the problem, in particular, in what context were those three lines of Python executed: from a file in a Python launched from a command line terminal window, typed into a Python in a command line terminal window, from within an IDLE shell window, from an IDLE edit window?  How exactly did Python crash (what error messages were reported)? Also please paste the output from running in a terminal shell window:

python3.8 -m test.pythoninfo

replacing python3.8 with whatever you use to invoke the Python that fails.
msg378939 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-10-19 10:52
Also: What's meant by "crash OSX 10.14.6"?

Could this be a duplicate of #37833?
msg379006 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-10-19 20:22
> Could this be a duplicate of #37833?

I suppose it's possible if not using a python.org Python.

I'm not able to reproduce this with a current Python 3.9.0 on macOS 10.15.7. 

I'm going to close this for now.  If someone is able to provide more information on how to reproduce this, please re-open.
History
Date User Action Args
2020-10-19 20:22:36ned.deilysetstatus: open -> closed
resolution: works for me
messages: + msg379006

stage: resolved
2020-10-19 10:52:05ronaldoussorensetmessages: + msg378939
2020-09-01 06:46:21ned.deilysetmessages: + msg376181
2020-08-31 18:24:58dulcimoosettype: crash
2020-08-31 18:24:37dulcimoocreate