classification
Title: GH-21658: Add snake game to tools/demo!
Type: Stage: resolved
Components: Tkinter Versions: Python 3.8
process
Status: closed Resolution: rejected
Dependencies: Superseder: Add snake example to turtledemo
View: 41380
Assigned To: terry.reedy Nosy List: Ehsonjon Gadoev, terry.reedy
Priority: normal Keywords: patch

Created on 2020-07-28 14:08 by Ehsonjon Gadoev, last changed 2020-07-29 07:59 by Ehsonjon Gadoev. This issue is now closed.

Files
File name Uploaded Description Edit
snake.py Ehsonjon Gadoev, 2020-07-28 14:08 Code of game
Pull Requests
URL Status Linked Edit
PR 21658 closed Ehsonjon Gadoev, 2020-07-28 14:11
Repositories containing patches
https://github.com/python/cpython/pull/21658
Messages (3)
msg374492 - (view) Author: Ehsonjon Gadoev (Ehsonjon Gadoev) * Date: 2020-07-28 14:08
Its simple snake game for beginners! It based on simple algorithm! If you know! And it must be on python/cpython repo! Cause, I made python (snake) game with Python Programming Language xD (maybe not funny)!

We love python as much as you do! Yea!
msg374533 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-07-28 21:55
This is a duplicate of the original issue, #41380, except that it proposes to put the new file where it does not belong and will be useless, instead of in turtledemo.
msg374563 - (view) Author: Ehsonjon Gadoev (Ehsonjon Gadoev) * Date: 2020-07-29 07:59
I knew, but its not support for turtledemo cause, canvas is so small for this example! Mr @terry.reedy!!
History
Date User Action Args
2020-07-29 07:59:00Ehsonjon Gadoevsetmessages: + msg374563
2020-07-28 21:55:59terry.reedysetstatus: open -> closed

superseder: Add snake example to turtledemo
assignee: terry.reedy

nosy: + terry.reedy
messages: + msg374533
resolution: rejected
stage: patch review -> resolved
2020-07-28 14:15:40Ehsonjon Gadoevsettitle: Add snake game to tools/demo! -> GH-21658: Add snake game to tools/demo!
2020-07-28 14:12:56Ehsonjon Gadoevsethgrepos: + hgrepo390
2020-07-28 14:11:40Ehsonjon Gadoevsetkeywords: + patch
stage: patch review
pull_requests: + pull_request20803
2020-07-28 14:08:34Ehsonjon Gadoevcreate