classification
Title: help("modules ftp") fails due to test modules
Type: Stage: resolved
Components: Versions: Python 3.0
process
Status: closed Resolution: duplicate
Dependencies: Superseder: typo in a module describes utf-8 as uft-8
View: 4540
Assigned To: Nosy List: ajaksu2, throwaway
Priority: normal Keywords:

Created on 2008-10-16 22:05 by throwaway, last changed 2009-05-12 14:30 by ajaksu2. This issue is now closed.

Messages (2)
msg74871 - (view) Author: Alex Coventry (throwaway) Date: 2008-10-16 22:05
The modules test.bad_coding and test.badsyntax_pep3120.py cause the
command "help('modules ftp')" to fail with the errors 

LookupError: unknown encoding: uft-8

and

SyntaxError: Non-UTF-8 code starting with '\xf6' in file (null) on line
1, but no encoding declared; see http://python.org/dev/peps/pep-0263/
for details

respectively.  Removing these modules causes the help command to run
without error.  Not that that's a solution, just evidence for their
involvement in the problem.
msg87634 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-05-12 14:30
This is a duplicate of issue 4540.
History
Date User Action Args
2009-05-12 14:30:46ajaksu2setstatus: open -> closed

superseder: typo in a module describes utf-8 as uft-8

nosy: + ajaksu2
messages: + msg87634
resolution: duplicate
stage: resolved
2008-10-16 22:16:43throwawaysetversions: + Python 3.0
2008-10-16 22:05:35throwawaycreate