classification
Title: IDLE not saving .py files
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE: add missing import io in iomenu.py
View: 41300
Assigned To: terry.reedy Nosy List: nicklupe13, terry.reedy
Priority: normal Keywords:

Created on 2020-07-17 20:30 by nicklupe13, last changed 2020-07-17 22:45 by terry.reedy. This issue is now closed.

Messages (3)
msg373854 - (view) Author: Nick.Lupariello (nicklupe13) Date: 2020-07-17 20:30
IDLE will not save .py files. Neither Ctrl + S nor file -> Save file nor file -> Save file as function as intended and the .py file is not updated. 
This happens for both 32 bit and 64 bit distributions on multiple computers with 4 GB of ram running on a AMD A6-9220e RADEON R4. Tested installation in multiple locations. 
IDLE will not write to file anywhere in the file system including documents, desktop, and the installation folder itself.
msg373858 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-07-17 22:00
Add 'import io' to the top of <pythondir>/Lib/idlelib/iomenu.py.
msg373859 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-07-17 22:45
In calling this a duplicate, and suggesting the fix above, I am assuming that a) you are using the new 3.8.4 and b) you have a non-ascii character in the .py file or files you tested.  Since several years ago, the is the only case of save failing that I know of.  If either is not the case, please reopen and report exact os, python version, minimal file that does not save, and any other possibly relevant details you can think of.
History
Date User Action Args
2020-07-17 22:45:05terry.reedysetmessages: + msg373859
2020-07-17 22:00:59terry.reedysetstatus: open -> closed
superseder: IDLE: add missing import io in iomenu.py
messages: + msg373858

resolution: duplicate
stage: resolved
2020-07-17 20:30:19nicklupe13create