classification
Title: warning: 'Tk_Init' is deprecated: first deprecated
Type: compile error Stage: resolved
Components: macOS Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, ronaldoussoren, svaddi
Priority: normal Keywords:

Created on 2020-06-17 23:29 by svaddi, last changed 2020-10-19 16:01 by ronaldoussoren. This issue is now closed.

Files
File name Uploaded Description Edit
python.compile.log svaddi, 2020-06-17 23:29
Messages (1)
msg378958 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-10-19 16:01
The log shows a number of deprecation warnings in the Tcl/Tk headers included in the macOS SDK. That's just because Apple doesn't want you to use the system version of Tcl/Tk anymore.

The APIs themselves are fine if you use a non-system version of Tcl/Tk.
History
Date User Action Args
2020-10-19 16:01:41ronaldoussorensetstatus: open -> closed
type: compile error
messages: + msg378958

resolution: not a bug
stage: resolved
2020-06-17 23:29:34svaddicreate