classification
Title: warning: 'Tk_GetNumMainWindows' is deprecated
Type: compile error Stage: resolved
Components: macOS Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, ronaldoussoren, svaddi
Priority: normal Keywords:

Created on 2020-06-17 23:29 by svaddi, last changed 2020-10-19 18:49 by ronaldoussoren. This issue is now closed.

Files
File name Uploaded Description Edit
python.compile.log svaddi, 2020-06-17 23:29
Messages (1)
msg378984 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-10-19 18:49
This is not a bug in Python, but a warning from Apple that they don't want you to use the system provided Tcl/Tk libraries.

The Python.org installers are already build using a custom build of Tcl/Tk, mostly because the system provided build is ancient and buggy.
History
Date User Action Args
2020-10-19 18:49:43ronaldoussorensetstatus: open -> closed
type: enhancement -> compile error
messages: + msg378984

resolution: not a bug
stage: resolved
2020-06-17 23:29:09svaddicreate