classification
Title: IDLE: Malfunctioning of '\r'
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.10
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE: Document how Shell displays user code output
View: 23220
Assigned To: ezio.melotti Nosy List: Sanmitha Sadhishkumar, ezio.melotti, pmpp, terry.reedy
Priority: normal Keywords:

Created on 2020-05-21 09:41 by Sanmitha Sadhishkumar, last changed 2020-06-07 19:55 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
r Sanmitha Sadhishkumar, 2020-05-21 09:45 The description is given in the comment.
Screenshot_20200607-185043.png Sanmitha Sadhishkumar, 2020-06-07 13:23 The file shows the working of \r in my terminal
Messages (9)
msg369512 - (view) Author: Sanmitha (Sanmitha Sadhishkumar) Date: 2020-05-21 09:45
The escape sequence '\r' (carriage return) doesn't function in 3.x and 2.x versions.
Eg:
print("computer\rscience")
Expected output : sciencer
But, it displays computerscience without the functioning of'\r'
msg369515 - (view) Author: pmp-p (pmpp) * Date: 2020-05-21 09:50
Hi, i can't reproduce on standard terminals, what is your OS version and terminal application ( also please state value of $TERM )
msg369517 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2020-05-21 09:53
The behavior of \r depends on the operating system and terminal you are using, and not on Python itself.
msg369521 - (view) Author: Sanmitha (Sanmitha Sadhishkumar) Date: 2020-05-21 12:05
The escape sequence'\r' doesn't work in Windows operating system. All the versions including windows 10 doesn't support.
msg369552 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2020-05-21 23:21
Correct.  This is a Windows issue, not a Python one.
msg369688 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-05-23 02:22
Note that 'sciencecomputer' is a different possible result if \r does not switch the simulated terminal from the normal insert mode to overwrite mode.  I am considering terminal simulation as an option in IDLE, but there is not exactly a standard to emulate.
msg370895 - (view) Author: Sanmitha (Sanmitha Sadhishkumar) Date: 2020-06-07 13:23
This issue is not based on Windows or my terminal. This is purely an IDLE error. In Windows, both in command prompt and powershell \r functions properly.
msg370896 - (view) Author: Sanmitha (Sanmitha Sadhishkumar) Date: 2020-06-07 13:27
This issue is not based on Windows or my terminal. This is purely an IDLE error. In Windows, both in command prompt and powershell \r functions properly.
msg370910 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-06-07 19:55
Please stop spamming.  This is a duplicate of an existing issue.
History
Date User Action Args
2020-06-07 19:55:13terry.reedysetstatus: open -> closed

messages: + msg370910
versions: - Python 3.5, Python 3.6, Python 3.7, Python 3.8, Python 3.9
2020-06-07 19:51:50terry.reedysetfiles: - Screenshot_20200607-185043.png
2020-06-07 19:51:25terry.reedysetfiles: - r
2020-06-07 13:27:00Sanmitha Sadhishkumarsetstatus: closed -> open
files: + Screenshot_20200607-185043.png
messages: + msg370896
2020-06-07 13:23:08Sanmitha Sadhishkumarsetfiles: + Screenshot_20200607-185043.png

messages: + msg370895
versions: + Python 3.5, Python 3.6, Python 3.7, Python 3.8, Python 3.9
2020-05-23 02:22:08terry.reedysetversions: + Python 3.10, - Python 3.5, Python 3.6, Python 3.7, Python 3.8
superseder: IDLE: Document how Shell displays user code output
title: Malfunctioning of '\r' (ii) -> IDLE: Malfunctioning of '\r'
messages: + msg369688

resolution: not a bug -> duplicate
2020-05-21 23:21:02ezio.melottisetstatus: open -> closed
resolution: not a bug
messages: + msg369552
2020-05-21 12:05:54Sanmitha Sadhishkumarsetstatus: closed -> open
files: + r
title: Malfunctioning of '\r' -> Malfunctioning of '\r' (ii)
messages: + msg369521

resolution: not a bug -> (no value)
2020-05-21 09:53:15ezio.melottisetstatus: open -> closed

type: performance -> behavior
assignee: terry.reedy -> ezio.melotti

nosy: + ezio.melotti
messages: + msg369517
resolution: not a bug
stage: resolved
2020-05-21 09:50:54pmppsetnosy: + pmpp
messages: + msg369515
2020-05-21 09:45:01Sanmitha Sadhishkumarsetfiles: + r

messages: + msg369512
2020-05-21 09:41:08Sanmitha Sadhishkumarcreate