classification
Title: Building with a libreadline.so located outside the ld.so.conf search path fails
Type: compile error Stage:
Components: Extension Modules Versions: Python 3.9, Python 3.8, Python 3.7
process
Status: open Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mjpieters
Priority: normal Keywords:

Created on 2020-05-16 15:27 by mjpieters, last changed 2020-05-16 15:54 by mjpieters.

Messages (3)
msg369054 - (view) Author: Martijn Pieters (mjpieters) * Date: 2020-05-16 15:27
This issue goes back a long time. The libreadline handling in the modules setup.py doesn't add the location of the readline library to the runtime library paths:

    self.add(Extension('readline', ['readline.c'],
                       library_dirs=['/usr/lib/termcap'],
                       extra_link_args=readline_extra_link_args,
                       libraries=readline_libs))

This requires the readline library to have been added to a traditional location or has taken care of either ld.so.conf or LD_LIBRARY_PATH.

I'm building a series of Python binaries with a custom `--prefix` where I also installed a local copy of readline (so both are configured with the same prefix), and while setup.py finds the correct library, importing the compiled result fails because no `RPATH` is set.

This could be fixed by adding the parent path of the located `libreadline` shared library as a `runtime_library_dirs` entry:

    readline_libdirs = None
    if do_readline not in self.lib_dirs:
        readline_libdirs = [
            os.path.abspath(os.path.dirname(do_readline))
        ]

    self.add(Extension('readline', ['readline.c'],
                       library_dirs=['/usr/lib/termcap'],
                       extra_link_args=readline_extra_link_args,
                       runtime_library_dirs=readline_libdirs,
                       libraries=readline_libs))
msg369055 - (view) Author: Martijn Pieters (mjpieters) * Date: 2020-05-16 15:46
Actually, this won't do it either, as `self.lib_dirs` already contains the --prefix.

Clearly, I just need to add -R=${PREFIX}/lib to CPPFLAGS.
msg369057 - (view) Author: Martijn Pieters (mjpieters) * Date: 2020-05-16 15:54
Last but not least, this is essentially a duplicate of https://bugs.python.org/issue4010
History
Date User Action Args
2020-05-16 15:54:44mjpieterssetmessages: + msg369057
2020-05-16 15:46:11mjpieterssetresolution: not a bug
messages: + msg369055
2020-05-16 15:27:30mjpieterscreate