classification
Title: test_subprocess stuck on Windows, x64
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Dima.Tisnek, paul.moore, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2020-05-11 05:44 by Dima.Tisnek, last changed 2020-05-16 03:00 by terry.reedy. This issue is now closed.

Messages (3)
msg368614 - (view) Author: Dima Tisnek (Dima.Tisnek) * Date: 2020-05-11 05:44
The windows test got stuck in my PR, and I'm pretty sure my change is not to blame.

The test log looks like this:

0:11:10 load avg: 6.42 [421/423] test_importlib passed
0:11:40 load avg: 5.40 running: test_subprocess (58.5 sec), test_multiprocessing_spawn (53.0 sec)
0:12:10 load avg: 5.48 running: test_subprocess (1 min 28 sec), test_multiprocessing_spawn (1 min 23 sec)
0:12:40 load avg: 5.44 running: test_subprocess (1 min 58 sec), test_multiprocessing_spawn (1 min 53 sec)
0:12:57 load avg: 4.58 [422/423] test_multiprocessing_spawn passed (2 min 10 sec) -- running: test_subprocess (2 min 16 sec)
0:13:27 load avg: 2.89 running: test_subprocess (2 min 46 sec)
0:13:57 load avg: 2.11 running: test_subprocess (3 min 16 sec)
0:14:27 load avg: 1.54 running: test_subprocess (3 min 46 sec)
...
5:53:33 load avg: 0.48 running: test_subprocess (5 hour 42 min)
5:54:03 load avg: 0.51 running: test_subprocess (5 hour 43 min)
5:54:33 load avg: 0.31 running: test_subprocess (5 hour 43 min)
Terminate batch job (Y/N)? 

https://github.com/python/cpython/pull/19402/checks?check_run_id=658308339
msg369001 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-05-16 02:27
python -m test.testsubprocessing on my Win 10-64 with repository 3.9.0a6+, without your patch, produces

minkernel\crts\ucrt\src\appcrt\lowio\write.cpp(49) : Assertion failed: (_osfile(fh) & FOPEN)
minkernel\crts\ucrt\src\appcrt\lowio\close.cpp(49) : Assertion failed: (_osfile(fh) & FOPEN)
.minkernel\crts\ucrt\src\appcrt\lowio\close.cpp(49) : Assertion failed: (_osfile(fh) & FOPEN)

followed by

Ran 313 tests in 43.808s
OK (skipped=180)

Since, I presume, you are not working on Windows, I made a PR branch, recompiled, and reran test_subprocess.  Same result.  So I triggered a rerun in case the error was an oddball or in case cpython has changed.

Did not work.  Try close and re-open instead.  Appears to be working better.
msg369003 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-05-16 03:00
CI now passes.
History
Date User Action Args
2020-05-16 03:00:12terry.reedysetstatus: open -> closed
type: behavior
messages: + msg369003

resolution: not a bug
stage: resolved
2020-05-16 02:27:53terry.reedysetnosy: + terry.reedy
messages: + msg369001
2020-05-11 05:44:58Dima.Tisnekcreate