classification
Title: ProactorEventLoop fails on recvfrom with IPv6 sockets
Type: behavior Stage: resolved
Components: asyncio Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: asvetlov, kbr, yselivanov
Priority: normal Keywords:

Created on 2020-03-22 09:59 by kbr, last changed 2020-03-22 10:20 by kbr. This issue is now closed.

Files
File name Uploaded Description Edit
udp_ipv6_server.py kbr, 2020-03-22 09:59 regression test case
Messages (2)
msg364794 - (view) Author: Kjell Braden (kbr) * Date: 2020-03-22 09:59
on Windows 10 with Python 3.8.2 and Python 3.9.0a4, the ProactorEventLoop raises "OSError: [WinError 87] The parameter is incorrect" when recvfrom on an AF_INET6 socket returns data:


DEBUG:asyncio:Using proactor: IocpProactor
INFO:asyncio:Datagram endpoint local_addr=('::', 11111) remote_addr=None created: (<_ProactorDatagramTransport fd=288>, <__main__.Prot object at 0x0000028739A09580>)
ERROR:root:error_received
Traceback (most recent call last):
  File "...\Python\Python39\lib\asyncio\proactor_events.py", line 548, in _loop_reading
    res = fut.result()
  File "...\Python\Python39\lib\asyncio\windows_events.py", line 808, in _poll
    value = callback(transferred, key, ov)
  File "...\Python\Python39\lib\asyncio\windows_events.py", line 496, in finish_recv
    return ov.getresult()
OSError: [WinError 87] The parameter is incorrect


The same code works without issues on python 3.7 or when using WindowsSelectorEventLoopPolicy.
msg364795 - (view) Author: Kjell Braden (kbr) * Date: 2020-03-22 10:20
sorry - is a duplicate of https://bugs.python.org/issue39148
History
Date User Action Args
2020-03-22 10:20:39kbrsetstatus: open -> closed
resolution: duplicate
messages: + msg364795

stage: resolved
2020-03-22 09:59:42kbrcreate