classification
Title: Commands running in 3.7.6 Shell, but failing as script
Type: Stage: resolved
Components: Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: rosarion, terry.reedy
Priority: normal Keywords:

Created on 2020-03-16 07:18 by rosarion, last changed 2020-03-20 20:03 by terry.reedy. This issue is now closed.

Messages (2)
msg364293 - (view) Author: Noel del rosario (rosarion) Date: 2020-03-16 07:18
Python 3.7.6 (tags/v3.7.6:43364a7ae0, Dec 19 2019, 00:42:30) [MSC v.1916 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license()" for more information.

from future import absolute_import, division, print_function, unicode_literals
import numpy as np
import matplotlib.pyplot as plt
import tensorflow as tf
from tensorflow import keras
print(tf.version)
2.1.0

BUT IF I RUN THESE COMMANDS as a PYTHON SCRIPT FILE iy FAILS.
======================== RESTART: D:\PythonCode-1\tmp.py =======================
Traceback (most recent call last):
File "D:\PythonCode-1\tmp.py", line 7, in
import tensorflow as tf
File "C:\Python37\lib\site-packages\tensorflow_init_.py", line 101, in
from tensorflow_core import *
File "C:\Python37\lib\site-packages\tensorflow_core_init_.py", line 40, in
from tensorflow.python.tools import module_util as _module_util
ModuleNotFoundError: No module named 'tensorflow.python.tools'; 'tensorflow.python' is not a package

Why is it failing as a Script file ?
Is there something wrong in my Procedure ?

Hope to teceive your reply and Thanks in Advanced.
msg364712 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-03-20 20:03
This tracker is for improving future versions of python.  Questions about using current python belong on python-list or other help forums, such as stackoverflow.  Reading the following will help you ask good questions.
https://stackoverflow.com/help/minimal-reproducible-example

A few notes:
1. The minimal example is likely 'import tensorflow as tf'.
2. The 'shell' part of your post is not copied from an interactive session (IDLE?), as there are no prompts.
3. The typical reason for the same import working and then not working is running the import with two different python binaries with different installed 3rd-party packages.  If you ran twice in the same IDLE, once interactively and once from an editor, that would not be an issue, and I would not know why the difference.
4. Tensorflow keras assumes that it is outputting to a text terminal, which IDLE is not, so there may be glitches in output formatting.
History
Date User Action Args
2020-03-20 20:03:14terry.reedysetstatus: open -> closed

title: Group of commands running in Python 3.7.6 Shell, but failing as Script file. -> Commands running in 3.7.6 Shell, but failing as script
nosy: + terry.reedy

messages: + msg364712
resolution: not a bug
stage: resolved
2020-03-16 07:18:39rosarioncreate