classification
Title: referendum reference is needlessly annoying
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.9, Python 3.8, Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: willingc Nosy List: akuchling, diziet, docs@python, fdrake, mark.dickinson, opensource-assist, rhettinger, steven.daprano, terry.reedy, willingc
Priority: low Keywords:

Created on 2020-01-28 17:07 by diziet, last changed 2020-02-03 19:46 by rhettinger. This issue is now closed.

Messages (6)
msg360883 - (view) Author: Ian Jackson (diziet) Date: 2020-01-28 17:07
The section "Fancier Output Formatting" has the example below.  This will remind many UK readers of the 2016 EU referendum.  About half of those readers will be quite annoyed.

This annoyance seems entirely avoidable; a different example which did not refer to politics would demonstrate the behaviour just as well.

Changing this example would (in the words of the CoC) also show more empathy, and be more considerate towards, python contributors unhappy with recent political developments in the UK, without having to make anyone else upset in turn.

  >>> year = 2016
  >>> event = 'Referendum'
  >>> f'Results of the {year} {event}'
  'Results of the 2016 Referendum'

  >>> yes_votes = 42_572_654
  >>> no_votes = 43_132_495
  >>> percentage = yes_votes / (yes_votes + no_votes)
  >>> '{:-9} YES votes  {:2.2%}'.format(yes_votes, percentage)' 42572654 YES votes  49.67%'
msg360906 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2020-01-28 22:09
Oh come on now, this is such a trivialisation of the CoC that I cannot believe that it is a good-faith bug report and not a troll. I'm surprised you didn't toss in the words "triggered" and "micro-aggression" while you're at it.

The example has nothing to do with the UK Referendum (or for that matter, the 2016 referendums in Zambia, Columbia, Bolivia, or Italy): the numbers are completely different, the results and percentages are different, and there is no non-arbitrary way to map Yes/No of a made up example to either Leave/Remain or any other actual results. If you want to read the example as a better world where the majority of peole voted "No" to leaving the EU, then go ahead.

Why should you privilege the Brexit referendum over (let's say) the Irish referendum which voted in favour of allowing same-sex marriages? Or are you annoyed by that too?

Any year is going to "annoy" some fraction of the readers:

2019 is the year that the Liberal Party (don't be fooled by the name: they're the authoritarian-right, climate-change-denying reactionary-right party) won the Australian Federal election on a campaign of Facebook fake news, "annoying" almost half the country. It is also the year that President Trump was impeached, annoying half of the USA. 2018 was the year Vladimir Putin was re-elected president of Russia, annoying and *terrifying* some percentage of Russians. 2017 was the year that Trump was sworn in as US President. Shall we go on?

2016 was also the year that Taiwan saw the first ever majority by a non-KMT party, and the first female prime minister, when the Democratic Progressive Party won their elections.

By the way, the fact that I've just spent easily half an hour getting annoyed at this bug report and writing this response disproves your claim about avoiding making others upset.
msg360910 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2020-01-28 23:10
I concur with Steven.  The association with Brexit is specious and the CoC wasn't intended to apply to second guessing technical examples.
msg360939 - (view) Author: Aurora (opensource-assist) * Date: 2020-01-29 07:13
This example is practically against Python's diversity statement.
msg361133 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-01-31 20:28
I concur with Steven and Raymond.  The 2016 Brexit votes were Leave 17.4 million and Remain 16.1 million.  No resemblence to the hypothetical example.  I think that this should be closed as 'not a bug'.
msg361321 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2020-02-03 18:58
Speaking as a British, UK-based Python contributor who's unhappy with recent political developments in the UK, I say let's close this.
History
Date User Action Args
2020-02-03 19:46:48rhettingersetstatus: open -> closed
resolution: not a bug
stage: resolved
2020-02-03 18:58:56mark.dickinsonsetnosy: + mark.dickinson
messages: + msg361321
2020-02-03 18:27:33opensource-assistsettype: enhancement
2020-01-31 20:28:17terry.reedysetnosy: + terry.reedy
messages: + msg361133
2020-01-29 07:13:43opensource-assistsetnosy: + opensource-assist
messages: + msg360939
2020-01-28 23:10:55rhettingersetpriority: normal -> low

nosy: + willingc, rhettinger
messages: + msg360910

assignee: docs@python -> willingc
2020-01-28 22:09:23steven.dapranosetnosy: + steven.daprano
messages: + msg360906
2020-01-28 18:12:33fdrakesetnosy: + fdrake
2020-01-28 17:17:00serhiy.storchakasetnosy: + akuchling
2020-01-28 17:07:14dizietcreate