classification
Title: shutil.move does not work properly with pathlib.Path objects
Type: behavior Stage: resolved
Components: Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: shutil.move raises AttributeError if first argument is a pathlib.Path object and destination is a directory
View: 32689
Assigned To: Nosy List: Luca Paganin, xtreak
Priority: normal Keywords:

Created on 2019-12-26 23:39 by Luca Paganin, last changed 2019-12-27 03:13 by xtreak. This issue is now closed.

Files
File name Uploaded Description Edit
mover.tgz Luca Paganin, 2019-12-26 23:39
Messages (2)
msg358891 - (view) Author: Luca Paganin (Luca Paganin) Date: 2019-12-26 23:39
Suppose you have two pathlib objects representing source and destination of a move:

src=pathlib.Path("foo/bar/barbar/myfile.txt")
dst=pathlib.Path("foodst/bardst/")

If you try to do the following

shutil.move(src, dst)

Then an AttributeError will be raised, saying that PosixPath objects do not have an rstrip attribute. The error is the following:

Traceback (most recent call last):
  File "mover.py", line 10, in <module>
    shutil.move(src, dst)
  File "/Users/lucapaganin/opt/anaconda3/lib/python3.7/shutil.py", line 562, in move
    real_dst = os.path.join(dst, _basename(src))
  File "/Users/lucapaganin/opt/anaconda3/lib/python3.7/shutil.py", line 526, in _basename
    return os.path.basename(path.rstrip(sep))
AttributeError: 'PosixPath' object has no attribute 'rstrip'

Looking into shutil code, line 526, I see that the problem happens when you try to strip the trailing slash using rstrip, which is a method for strings, while PosixPath objects do not have it. Moreover, pathlib.Path objects already manage for trailing slashes, correctly getting basenames even when these are present.
The following two workarounds work:

1) Explicit cast both src and dst as string using

shutil.move(str(src), str(dst))

This work for both the cases in which dst contains the destination filename or not.

2) Add the filename to the end of the PosixPath dst object:

dst=pathlib.Path("foodst/bardst/myfile.txt")

Then do 

shutil.move(src, dst)

Surely one could use the method pathlib.Path.replace for PosixPath objects, which does the job without problems, even if it requires for dst to contain the destination filename at the end, and lacks generality, since it bugs when one tries to move files between different filesystems. 
I think that you should account for the possibility for shutil.move to manage pathlib.Path objects even if one does not provide the destination filename, since the source of the bug is due to a safety measure which is not necessary for pathlib.Path objects, i.e. the managing of the trailing slash.
Do you think that is possible? Thank you in advance.

Luca Paganin

P.S.: I attach a tarball with the dirtree I used for the demonstration.
msg358894 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-12-27 02:14
This is a duplicate of https://bugs.python.org/issue32689 that is fixed in 3.9 . Using os.fspath on path object is more correct here instead of str so that objects with both __str__ and __fspath__ implemented are handled properly.
History
Date User Action Args
2019-12-27 03:13:08xtreaksetstatus: open -> closed
superseder: shutil.move raises AttributeError if first argument is a pathlib.Path object and destination is a directory
resolution: duplicate
stage: resolved
2019-12-27 02:14:11xtreaksetnosy: + xtreak
messages: + msg358894
2019-12-26 23:39:08Luca Paganincreate