classification
Title: Misleading documentation for tuple
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.9, Python 3.8, Python 3.7, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Fix some class entries in 'Built-in Functions'
View: 34118
Assigned To: docs@python Nosy List: docs@python, sberens, terry.reedy, xtreak
Priority: normal Keywords:

Created on 2019-12-21 01:28 by sberens, last changed 2019-12-28 22:05 by terry.reedy. This issue is now closed.

Messages (4)
msg358753 - (view) Author: Simon Berens (sberens) Date: 2019-12-21 01:28
Sorry if this is a silly question (my first bug report), but it seems that https://docs.python.org/3/library/functions.html#func-tuple
should say "class tuple" instead of just "tuple", as list, dict, and set do.
msg358809 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-12-23 12:09
FWIW, built-in types page has the class prefix : https://docs.python.org/3/library/stdtypes.html#tuple . Similar difference between range in the two pages.
msg358932 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2019-12-28 07:21
I believe that this is a duplicate issue.  As noted before, filter, map, reversed, and zip are classes, but they return iterators and are documented differently.
msg358933 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-12-28 08:09
Thanks Terry, I guess it's a duplicate of issue34118 .
History
Date User Action Args
2019-12-28 22:05:03terry.reedysetstatus: open -> closed
superseder: Fix some class entries in 'Built-in Functions'
resolution: duplicate
stage: resolved
2019-12-28 08:09:54xtreaksetmessages: + msg358933
2019-12-28 07:21:22terry.reedysetnosy: + terry.reedy

messages: + msg358932
versions: - Python 3.5, Python 3.6
2019-12-23 12:09:34xtreaksetnosy: + xtreak
messages: + msg358809
2019-12-21 01:28:19sberenscreate