classification
Title: Segfault on build for the master branch
Type: Stage: resolved
Components: Build Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: nanjekyejoannah, pablogsal, vstinner, zach.ware
Priority: normal Keywords:

Created on 2019-12-14 06:34 by nanjekyejoannah, last changed 2019-12-14 11:07 by vstinner. This issue is now closed.

Messages (5)
msg358379 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2019-12-14 06:34
I just pulled changes from upstream and when I build with:

./configure --with-pydebug && make -j

Am getting a Segmentation fault:

./python -E -S -m sysconfig --generate-posix-vars ;\
if test $? -ne 0 ; then \
        echo "generate-posix-vars failed" ; \
        rm -f ./pybuilddir.txt ; \
        exit 1 ; \
fi
 CC='gcc -pthread' LDSHARED='gcc -pthread -shared    ' OPT='-g -Og -Wall'       _TCLTK_INCLUDES='' _TCLTK_LIBS=''       ./python -E ./setup.py  build
Segmentation fault (core dumped)
make: *** [Makefile:614: sharedmods] Error 139

I hope someone else can replicate this on:

o LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 19.04
Release:        19.04
Codename:       disco
msg358380 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2019-12-14 06:46
If you updated an unclean checkout, try running `make distclean` before configuring and building again; that often clears this kind of thing up.
msg358381 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2019-12-14 06:53
Actually my master had some segfaulting changes that I had moved to it in error. Thanks.

Closing this.
msg358382 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2019-12-14 07:01
Confirmed....forgeting to run makedistclean was the problem.
msg358388 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-12-14 11:07
> Confirmed....forgeting to run makedistclean was the problem.

Yeah, it happens often to me.

If "make distclean" is not enough, I move untracked files outside the Python repository and run "git clean "-fdx" which removes *all* untracked files. Use "git clean -ndx" to see which files will be removed, to double check. Otherwise, you may loose sensitive files which are not tracked by Git.
History
Date User Action Args
2019-12-14 11:07:16vstinnersetmessages: + msg358388
2019-12-14 07:01:03nanjekyejoannahsetmessages: + msg358382
2019-12-14 06:53:30nanjekyejoannahsetstatus: open -> closed
resolution: not a bug
messages: + msg358381

stage: resolved
2019-12-14 06:46:20zach.waresetnosy: + zach.ware
messages: + msg358380
2019-12-14 06:38:49nanjekyejoannahsetnosy: + vstinner, pablogsal
2019-12-14 06:34:52nanjekyejoannahcreate