classification
Title: incorrect prefix, exec_prefix in distutils.command.install
Type: behavior Stage: resolved
Components: Distutils Versions: Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: dstufft, eric.araujo, xdegaye
Priority: normal Keywords:

Created on 2019-12-01 14:01 by xdegaye, last changed 2019-12-09 14:16 by xdegaye. This issue is now closed.

Messages (2)
msg357678 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2019-12-01 14:01
In function finalize_options() of Lib/distutils/command/install.py at

https://github.com/python/cpython/blob/575d0b46d122292ca6e0576a91265d7abf7cbc3d/Lib/distutils/command/install.py#L284

(prefix, exec_prefix) is set using get_config_vars(). This may be incorrect when Python has been manually copied in another location from the location where it has been installed with 'make install'. We should use sys.prefix and sy.exec_prefix instead, those values are calculated by getpath.c instead of being retrieved from the sysconfigdata module.
msg358095 - (view) Author: Xavier de Gaye (xdegaye) * (Python triager) Date: 2019-12-09 14:16
get_config_vars() defined in distutils.sysconfig sets 'prefix' and 'exec_prefix' using sys.prefix (resp. sys.exec_prefix) on non nt platforms so there is no problem. Closing the issue as not a bug.
History
Date User Action Args
2019-12-09 14:16:57xdegayesetstatus: open -> closed
resolution: not a bug
messages: + msg358095

stage: needs patch -> resolved
2019-12-01 14:01:26xdegayecreate