classification
Title: Python 2.6 doesn't run after installation on amd64
Type: behavior Stage:
Components: Windows Versions: Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: loewis Nosy List: jpe, loewis
Priority: critical Keywords:

Created on 2008-09-17 02:02 by jpe, last changed 2008-09-19 19:40 by jpe. This issue is now closed.

Files
File name Uploaded Description Edit
Microsoft.VC90.CRT.manifest loewis, 2008-09-18 18:35 amd64 manifest
Messages (5)
msg73322 - (view) Author: John Ehresman (jpe) * Date: 2008-09-17 02:02
The amd64 python 2.6rc1 won't run after installation on Vista.  It fails
with the error (from the event log) of 

Activation context generation failed for "C:\Python26\python.exe".Error
in manifest or policy file "C:\Python26\Microsoft.VC90.CRT.MANIFEST" on
line 11. Component identity found in manifest does not match the
identity of the component requested. Reference is
Microsoft.VC90.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8".
Definition is
Microsoft.VC90.CRT,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8".
Please use sxstrace.exe for detailed diagnosis.

Looking at the C:\Python26\Microsoft.VC90.CRT.MANIFEST file, the
processorArchitecture is set to x86
msg73396 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-09-18 18:35
I can't reproduce the problem. Did you install for all users, or just
for you? Do you have the CRT already installed or not?

Can you try replacing the manifest with the attached one (not sure why
it says x86)? You then also need to replace the manifest in DLLs, and
fix the  file name to "../msvcr90.dll".
msg73397 - (view) Author: John Ehresman (jpe) * Date: 2008-09-18 20:49
This is on a fresh Vista Ultimate install.  There is no msvcr90.dll
anywhere on the system, if windows file search according to windows file
search (I did check the hidden / system file box).

The first report is from a "for me" install.  After installing for all
users, there's no dll in \python26 and the error log error message of:
Activation context generation failed for "C:\Python26\python.exe".
Dependent Assembly
Microsoft.VC90.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="9.0.21022.8"
could not be found. Please use sxstrace.exe for detailed diagnosis.

I tried using changing the .manifest and got a null pointer access error:
Faulting application python.exe, version 0.0.0.0, time stamp 0x48cb6bcf,
faulting module ntdll.dll, version 6.0.6001.18000, time stamp
0x4791adec, exception code 0xc000007b, fault offset 0x00000000000b1188,
process id 0xa28, application start time 0x01c919c8f9746f89.

I wonder if the x86 dll is being installed rather than the amd64 one.
msg73429 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-09-19 15:27
You were right; the x86 version of the CRT was included. This is now
fixed in r66514 and r66515.

If you want to try it out, try

http://www.dcl.hpi.uni-potsdam.de/home/loewis/python-2.6rc2.amd64.msi
http://www.dcl.hpi.uni-potsdam.de/home/loewis/python-2.6rc2.amd64.msi.asc
msg73438 - (view) Author: John Ehresman (jpe) * Date: 2008-09-19 19:40
The new installer works for both for everyone and for me installs.

Thanks,

John
History
Date User Action Args
2008-09-19 19:40:44jpesetmessages: + msg73438
2008-09-19 15:27:39loewissetstatus: open -> closed
resolution: fixed
messages: + msg73429
2008-09-18 20:49:47jpesetmessages: + msg73397
2008-09-18 18:35:54loewissetfiles: + Microsoft.VC90.CRT.manifest
messages: + msg73396
2008-09-17 08:28:42amaury.forgeotdarcsetpriority: critical
assignee: loewis
nosy: + loewis
2008-09-17 02:02:33jpecreate