classification
Title: Break Statement
Type: Stage: resolved
Components: Windows Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: LewisGaul, dev40573, paul.moore, steve.dower, steven.daprano, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2019-10-14 19:31 by dev40573, last changed 2019-11-05 04:23 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
three.py dev40573, 2019-10-14 19:31
Messages (4)
msg354645 - (view) Author: DEVOR BLAKE DANIELS (dev40573) Date: 2019-10-14 19:31
The break statement in my AiO() function seems to cause my Uinput() function to malfunction.
msg354663 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2019-10-14 21:28
Define "malfunction". Are we supposed to know what your code is meant to do, as well as what it actually does?

Please don't use the bug tracker as a help desk for your own scripts. There are many forums where you can ask for help, such as the mailing lists, the Python Discuss forum, Stackoverflow, Reddit's r/learnpython etc.

If you are going to submit something here as a bug, please ensure that:

(1) it actually is a bug in the Python interpreter first, rather than a bug in your own code; and 

(2) you provide a MINIMAL example, with a description of the expected output, a reason why you expect it, and the actual output.

It may help for you to read this: http://sscce.org/
msg355986 - (view) Author: Lewis Gaul (LewisGaul) * Date: 2019-11-05 00:07
Should this issue be closed?
msg355997 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2019-11-05 04:23
Absent any response from the OP, I'm going to go with yes.

Devor, if you can reduce your example to show a bug in the Python interpreter or standard library, please reopen with that example.
History
Date User Action Args
2019-11-05 04:23:25zach.waresetstatus: open -> closed
resolution: not a bug
messages: + msg355997

stage: resolved
2019-11-05 00:07:45LewisGaulsetnosy: + LewisGaul
messages: + msg355986
2019-10-14 21:28:44steven.dapranosetnosy: + steven.daprano
messages: + msg354663
2019-10-14 19:31:02dev40573create