classification
Title: Undefined behavior when changing dict while iterating it
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.7, Python 3.6, Python 3.5, Python 2.7
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: bboneva
Priority: normal Keywords:

Created on 2019-10-04 16:54 by bboneva, last changed 2019-10-04 17:10 by bboneva. This issue is now closed.

Messages (2)
msg353954 - (view) Author: Beatris Boneva (bboneva) Date: 2019-10-04 16:54
When changing a dict while iterating through it by removing one key and inserting other which is calculated based on the old one, the dict is changed unexpectedly.

The following function:

```
def test(d: dict): 
     for i in d: 
         d[i+1] = d.pop(i)
```

when called with input dict `{1: 'test'}` transforms the dict to:
- `{6: 'test'}` in Python3.7.4;
- `{8: 'test'}` in Python3.5.3 and Python2.7.

If I change the function to add 2 to the key ( `d[i+2] = d.pop(i)` ) and use the same input `{1: 'test'}` the dict is changed to:
- `{11: 'test'}` in Python3.7;
- `{9: 'test'}` in Python3.5.

Similar thing happens with strings:

```
def test(d: dict): 
     for i in d: 
         d[i+'x'] = d.pop(i)
```

When called with input dict `{'a': 'test'}` it transforms it to:
- `{'axxxxx': 'test'}` in Python3.7.4;
- `{'axx': 'test'}` in Python3.5.3.
msg353960 - (view) Author: Beatris Boneva (bboneva) Date: 2019-10-04 17:10
Now I see it is duplicate of https://bugs.python.org/issue19332. Closing it.
History
Date User Action Args
2019-10-04 17:10:57bbonevasetstatus: open -> closed

messages: + msg353960
stage: resolved
2019-10-04 16:54:45bbonevacreate